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CHAPTER 3: MICROSTATION V8i BASICS

3.1 - MicroStation Design File Settings

3.1.1 - Setting Button Assignments

By default, the mouse buttons are assigned as shown below.

Default Button
Assignments

Data Button

Tentative Button (press at same time)

Reset Button
| /\\ J

Each of the buttons can be set to something different. For instance, if you
wanted to assign your mouse button as shown below follow the instruction
ahead.

Tentative

WheelMouse
optical

To set up the mouse buttons, go to Workspace->Button Assignments.....

In the Button Assignments dialog box under Buttons, choose Data. If the
assignment under “Invoked by” is anything other than Left Button then move the
mouse into the Button Definition Area and press the Left mouse button. In the
Button Assignments dialog box under Buttons, choose Tentative. If the
assignment under Invoked by is anything other than Middle Button then move
the mouse into the Button Definition Area and press the Middle mouse button
(the wheel). In the Button Assignments dialog box under Buttons, choose
Reset. If the assignment under Invoked by is anything other than Right Button
then move the mouse into the Button Definition Area and press the Right mouse
button.
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Finally, press the OK button.

Button Mappings

Buttons Invioked by i

Left Button
Tentative Middle Button —
Reset Right Button Cancel
AButton 1 Button 16
FButton 2 Button &

Default

HButton 3 Button & v

Button D efinition Area

Prezs the button pou want to use for <Data> here
You can use any mouse button or two-button chord

3.1.2 - Map a Mouse Button to Clear a Selection Set

Microstation V8i uses the power selector exclusively, sometimes an element from a previous
command will still be selected when the user selects a new element and performs another
action. The user may not be aware that the previous element was also modified. This button
assignment allows the user to hit a mouse button and automatically deselect everything

before performing a new task.

Filz
Buttonz
*Go to Workspace > Button Assignments. Co Ca [kt
Button:  *Button 4
*Select an empty button and, under Action, cior: [ choose nane |
H—T ” H H
type in “choose none” (without the quotation | g — 3
mar‘ks) AllfDala ] match attributes fromcursor
Shift+Tentative inputmanager menu tentativepopup
Clrl+T entative buttonaction kentative accudraw setorigin
. Al T entative buttonaction 3ddata

° H |t Rem ap B u ttO ns. Shift+Reset inputmanager menu viewpopup
Chil+Reset inputmanager menu main
Cl+5Shift+Resst inputmanager currenttask
Al+Reset mdl keyin elementinfo element quickinto fromeursor
#Button 1 pan drag
Shift+=Buttan 1 rotate view drag
Ctrl+<Button 1 navigate swivel
Alt+#Button 1 rotate view fromecursorn
b<Biuittan 4

Button Mappings

Select the button you chose in the

. . Buttons Invoked by - |
previous window, hover the mouse WButton 1 icklo Button =]
Niti #Butta 2 Buttan B
over the Button Definition Area, utton 2 Buon & 2 —
and click the button you wish to b<Bution 4 Button 4 =
use for this command. e e .

Button Definition Area

The Sma” bUtton on the Ieft Of a Press the button you want to use for <XButton 4> here
new LOgIteCh mouse’ (the one under You can use any mouse button or two-button chord
your thumb) work well for this.
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WARNING: if you choose a button already being used for something else (like the left or
right mouse button), whatever function it did before will now be assigned to this new button.

You should now be able to use the extra mouse button to deselect everything. You can
similarly map any other keyable command to the extra mouse buttons.

3.1.3 - Compress Design File

From the MicroStation dialog box, choose File > Compress > Design. This physically
removes all logically deleted elements.

3.1.4 - Save Settings

From the MicroStation dialog box, choose File > Save Settings. This saves all the
design file settings so that when the file is opened the next time, all the settings will be
restored.

3.2 — Level Assignments

3.2.1 — Introduction to Levels

To maintain uniformity among different drawing files, it is essential that an organized
leveling system be used. MicroStation V8i allows levels to be saved on a name basis
instead of previous number based system. A design file may contain an unlimited
number of levels on which data can be displayed. There are two primary ways in
which to assign symbology to each element: first, the color, weight, and line style of
the graphic elements are set independently. Second, a new addition introduced in
MicroStation V8 and maintained in V8i, is ByLevel symbology. With ByLevel
symbology each level may have a pre-assigned color, line style, and weight. By
selecting the desired level, these attributes are automatically set.

¢ In MicroStation V8i, levels and the associated ByLevel symbology are stored in
a DGN library, and may be attached to any MicroStation file. In order to
maintain the X30 criteria and future versions of Geopak criteria files, the
FLH_Combined.dgnllib is controlled FLH wide. EFLHD designers and A/E
Consultants will not be able to add new levels to the FLH_Combined.dgnllib file.

e For EFLHD employees, the standard DGN Library is automatically attached
when opening a design file using the Project Configuration (FLH_X30_English).

In EFLHD, most elements should be placed with the GEOPAK D&C
° Manager, the .ddb file. The D&C Manager is the best way to insure
z that elements are placed with the proper symbology. For final output
and for use at later stages with GEOPAK criteria files, and for
computing quantities.
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o All levels are named and have a default color, line weight, and style.
e Level definitions are stored and managed by “FLH_Combined.dgnlib”
e Levels have ByLevel Symbology and Override Symbology settings.

e Users shall not create their own levels for use in any design files submitted or
exchange with EFLHD. (See list of FLH levels in EFLHD CADD Manual)

e Levels can be managed by Level Manager and Level Display icons as shown
below.
Go to Setting > Levels > Manager

£e Level Manager

Levels Filter Edit
23 |20 | Symboloay: [Bylevel v ([ frone) + A ~

A Name

E_VEG_Special
%_E_Ground_X5
X_Geopak_Cell

Default

AlX_01

AlUX_02

= = Ued A

AUX_08
ALIX_09
AUX_10
D_CFL_Clip_Boundary_1
S

= O W N0 a wm = 0O NN

(=]

D~
]
I
I
]
I
]
L]

g
2
IEDOEEDECEENORDEG

Page 3-5




EFLHD CADD Procedures Guide — MicroStation V8i Edition

Chapter 3 -
MicroStation V8i Basics

3.3 — References

3.3.1 — Introduction to Reference Files

External design files can be attached to the current file as a reference.
Reference files maintain a dynamic link with the current file, allowing
changes in the attached references to be reflected in the current file.
Elements in the attached file display as though they are part of the current
file. References, however, are a one-way reference, in that you cannot edit
attached files while you are working in your current design.

A reference file must be a design (dgn) file or DWG (AutoCAD) file that is
attached to the design file in which you are currently working. User can also
attach the current file to itself. Drawing files in other format e.g. tiff file, pdf
file etc can be attached to your design file through Raster Manager.

A design file or dwg (Autocad) file can be attached to the design file through
the Reference Manager as shown below.

e Access Reference Manager through File > Reference

[Ei References (3 of 3 unique, 2 displayed)

Tools  Settings

E-Bxd $96 A3 DD 10 @ 0 e

Slat = ¥ 4| File Name Model Dezcription Logical Orie Presentation o] .7 & [Ell LL
E] O1-MC 2011-11]_pro_hwd.dagn LS Sur fr20  Global Origin aligne... 2-1 Cair ‘wireframe T v
2 M-HE 2011-1[1)_vark_PIPES_hyd.dgn US_Sur_fr2Dr  Aligned with Master.. 2 Coir ‘wireframe T o
1 02-MC fzr2011-1(1)_map.dan Global Origin aligne... Cair ‘Wireframe [P -

Sgale [ 1.000000 |- [ 1.000000 | Ratation | 00°00'00" | Offset [ 0.0000 | [ 0.0000 |

el ] > <

Geareferenced: | Mo

| Depth | 1

| Mew Level Display: | Canfig Yariable '+

] _.f= | No Nesting v| |AIIOW Overides
v
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¢ Once selected Tools>Attach to attach design file will activate Attach
Reference dialog as shown below.
Attach Reference - M:\PROJECTS\_FHWNH\nhfs16(1\TechserviSurvey\Right_Of_Way\Acquisition\FLT\FH7_Bear... [Z][¥]

& References {1 of 1 unique, Looke [ @ PH7_Beaothd yorrm H D -VBDEN

() EKP Wh\teMtnthEamntchMapping.dgn

@ |3 projdbs
m + ] My Recent 71 Describe Chain BEARNOTCH.docx

Documents IJl—WhlteMtnthearnntch_Chp.dgn
01-Whitetntbearnotch-Flan_Motif.dgn
§ Iﬂ BearMatch,pri

Desktop Dl dan

@gnngleearthimage.pdf
HighwayEasementDeed. docx

i
L
&

HighwayEasementDead,Bear Motch Rd.docx

|
&

]j07 .
My Documents I_J] n.ap.\np
|:\] j07ojp.inp Attachment Method
]D?oip.]‘uu Interactive b’
g‘ Iﬂ]obﬂl.gpk
Iﬂ]nbﬂ?.gpk

My Computer nhJ:lFh_wmnF(Flt)_BearNutch_tit\e_sht.dgn
nhjfhfwmnf(ﬂt),locfmap.dgn
B rh_pfh_wmnF(FIE)_title_sht.dan
Thumbs.db
My Metwork | 2] bripolird2 bt
Blaces WhlteMtntZdMapplng - Copy.dan

Enable the check box of Save ] hitebintbesrmatchaliment. don
Relative Path (recommended 2 | >

for all users) N

&

v Co=J

Files of type: Al Files [ v| [ Cancel ]
M - (15 ave Relative Patl ~d Options

Save Relative Path setting as shown in the Attach Reference dialog box
circled in red has essentially replaced the Save Full Path option of earlier
versions, Reference file attachments are searched for in the following manner if
not checked:

File name:

1. Active directory
2. Relative path directory
3. MS_RFDIR directory

4. Full path directory

e Select the design file to be referenced from the Attach Reference
dialog and click OK.
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Reference Attachment Settings for, nh_pfh_wmnf{fit)_BearNotc...

File Mame:  nh_pfh_wmnflfit)_BearNotch_title_sht.dgn
F
Hodel;

Logical Ma

Description: | Aligned with M azter Filz

Orientation:

View

dent - Wworld
ard Wigws

-

Glabal Origin aligned w

Coinci

ave G

Mamed Fences [none)

Detail Soale: |1"=40 v |
Scale [MasterRef) | 1000000 |: [1.000000 |
Mamed Group:
Fiewvisian:
Lewvel: w
Mested Attachments: | No Mesting b [epth:
Dizplay Overides: | Allow LT
Mew Level Display: | Use M5_REF_MEWLEWELL +
Global LineStyle Scale: | b aster e

Synchronize with Saved Yiew

Toogles = -
R LR
Drrawing Title
Create
Name: 22 |
L 1]4 J [ Cancel ]

e Select the Model you want to reference.
o ALWAYS select Coincident — World.
e Click OK to attach the selected model of the design file.
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3.4 — Models

3.4.1 — Introduction to Models

A V8i design file is a container of models, each of which behaves much like a
separate design file. MicroStation V8i design files can contain more than one
"model" -- each model is analogous to an entire design file. When you set up a new
DGN file in MicroStation V8i, you automatically create at least one model within your
new DGN, whether you know it or not. You can create an unlimited number of
models in a DGN file. Every model has its own set of eight views.

Design models can be either 2D or 3D. A design model can also be used as a
reference or placed as a cell. There are two types of models: DESIGN or SHEET.
By default, the view windows of design models have black backgrounds and those
of sheet models have white backgrounds (EFLHD Highway Design prefers Design
models rather than Sheet model, except when used for quantity sheets).

. In EFLHD’s configuration set up, Models are set to be created ALWAYS
z in 2D for 2D dgn files and 3D for 3D design files (Use the default seed
file “Sur_ft2D” for 2D dgn files and Sur_ft3D for 3D dgn files)

3.4.2- Models dialog box

MicroStation V8i offers a simple dialog box to manage models. The Models dialog
box can be accessed through File > Models or by clicking on the Models icon.

The Models dialog box is explained in the graphic below:

Copy a Model Edit Model Properties

Create a new Model Delete a Model

[8] Models =&

s activeFie | ] =3 B2 =P [

Type 20430 Mame

15 Design File

Type of Model CHEPENCER. MISCACADD COOH

odel is 2D or 3D odel can be placed as a Cell

|
| ™
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3.4.2- Tips on Models

e To switch between the models, you simply double-click on the model name in the
Models dialog box or select a view group associated with the desired model.

¢ Each model has its own reference attachments. When you attach a reference,
one of the new parameters you set is to enable the model to access part of the
reference definition.

e You can also drag and drop DGN or DWG files from Windows Explorer into the
Models dialog box to import the models from the selected files. Similarly you can
use drag and drop to drag models from the Models dialog in another open
session of V8i to the Models list box and drop them in to import the models.

EFLHD prefers to use Models on the following sheets of PS&E Plan set.

i o Typical Sections (If you have more than one sheet of Typical Sections, use
model).
¢ Quantity Sheets (Use EFLHD Quantity sheet with Excel file).
Plan sheet, Plan & Profile Sheet, E&S sheets, Striping Plan sheets etc.,
see Plan &Profile Sheet clipping.
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