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Chapter 1 -  Geopak – Basic 

1.1 -  Introduction 

GEOPAK V8i Edition, the civil engineering design software in use at Eastern Federal 
Lands Highway Division (EFLHD), is a comprehensive software package that covers 
every project phase from conceptualization to final quantities and construction stake-out. 
The software works within the MicroStation V8i graphic environment providing true 
interactive design. As with any powerful software, and many complex processes, there 
are many different ways to accomplish a given task.  This guide will outline the 
necessary procedures to ensure proper adherence to EFLHD standards for project 
design. 

 

The BASIC steps of a GEOPAK design are as follows:                                                                                    
(These steps may be adjusted depending on the type of projects and personal 
preferances). 

Step I-  Get the .TIN file and mapping file from our Survey Branch. The mapping file 
usually has an extension of “***_map.dgn” (for existing planimetric features).  

 In order to create Profile, Cross Sections, Earthwork, or 3D models with 
GEOPAK you must have a Digital Terrain Module (DTM) file that is compatible 
with GEOPAK Software. The  GEOPAK default DTM file is known as the .TIN 
file.  This is an abbreviation for “triangulated irregular network”. The .TIN file is 
usually made from the field data file by the Survey section. So rather than get 
into how to make the .TIN file I will simply say, “Get the .TIN file from Survey.” 

 Currently, it is the responsibility of the Survey Branch to provide the mapping 
and .TIN file to design. These files will normally located at    
“M:\Projects\project directory… \techserv\survey\FinalMapping\” directory 
at EFLHD. 

Step II- Create a horizontal alignment. This can be done several ways, either through 
Coordinate Geometry or through Interactive Horizontal Design.  

Step III-  Display and Annotate the horizontal alignment graphically.  

Step IV-   Generate the existing ground profile.  

Step V- Display the “existing ground” profile graphically. This can be done two ways. 

Step VI-   Create the vertical alignment. This can be done several ways, either through 
Coordinate Geometry or through Interactive Vertical Design.  

Step VII- Display the “design” profile graphically. This can be done two ways.  

Step VIII – Design any required/desired widening.  
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Step IX – Develop Plan and Profile Sheets. 

Step X – Generate the superelevation, (the Shapes).  

Step XI- Draw Pattern lines across the horizontal alignments (for location of cross 
sections).  

Step XII- Generate the existing ground cross sections.  

Step XIII- Generate the proposed cross sections.  

Step XIV- Develop Cross Section Sheets.  

Step XV- Generate the construction limits for the plan view.  

Step XVI- Calculate the earthwork.  

Step XVII- Generate any miscellaneous staking reports.  

Step XVIII- Generate a 3D model.    

 

1.1 -  Geopak Files Names 
 

Geopak uses and /or creates files during the design process. Several of the more 
common files are detailed shown below. 

 

Job###.gpk: 

This is Geopak Coordinate Geometry file where all coordinate geometry elements are 
stored. GPK file is comprised of stored geometric elements such as points, lines, 
curves, spirals, chains, parcels and profiles. This binary file is created when the user 
starts a coordinate geometry (COGO) session for the first time. Multiple users can 
access this file at the same time, and only one file should be created for each project. 
The “###” is the only variable in this filename. It represents a job number (up to 3 
alphanumeric characters) unique to a project and is defined by the user upon creation.  
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In EFLHD the Job number will be assigned by the CADD Coordinator for 
all the projects. 

          (See MicroStation V8i Section 2.2.3 for gpk number naming convention) 

Project‐name.prj:  

It is a binary file resulting from the creation of a new project. It stores information for 
use by the Geopak Project manager.  

The name specified must be a valid Windows file name (i.e., it cannot contain the 
special characters \ /: *? “ < > | ).  Although there is no standard naming convention 
used for .prj files in EFLHD, it’s good practice to use a name that relates to the 
project’s  route designation because the Project Name specified here is used to 
access the Project Manager setup for the project in subsequent sessions. 

fname###.ioc  

ASCII input file for loading data during a COGO session. "###" Represents the job 
number and "oc" is the operator code (users initials). Filename characters are limited 
to 5 characters plus the 3 job number character designation as indicated with the 
example. 

fname###.ooc   

ASCII output file created by GEOPAK during a COGO session. Variables are the 
same as defined above. Filename characters are limited to 5 characters plus the 3 job 
number character designation as indicated with the example. 

fname.tin     

A binary file containing triangular surfaces also known as the digital terrain model 
(DTM).  
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1.3 -  GEOPAK User Preferences 

 When a user begins Geopak for the first time or after Geopak has been 
reloaded, there are certain User Preferences the user needs to set. The User 
Preferences dialog box can be accessed from Applications > Geopak > Road 
> User Preferences. The following dialog box appears; 

 

 

 

 

 

 

 

 

 

 

The Working Directory identifies where the data files for a particular project can be 
found. If a user does not want to work within a specific project, the field may be left 
blank, and Geopak uses the directory wherein the open MicroStation file is located.  

Note - EFLHD designers usually work on more than one 
project at a time; the field should be left blank ALWAYS as 
a default preference.   

 By clicking the Feature Preferences button, the following dialog box is 
invoked.  
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This defines the default file utilized for representation of coordinate geometry 
and survey elements when visualization is utilized during an active coordinate 
geometry session as well as the scale in which these elements will be 
displayed. 

By pressing the COGO Preferences button, the following dialog box is invoked.  

 

The Job (GPK) Directory field specifies the location of the GPK file. If any of 
the above directory fields are blank, they will default to the Working Directory 
set in the GEOPAK User preferences dialog box (EFLHD’s preferred set up- 
Kept blank as above shown directory). 

1.4 - Setting Up Project Manager (Geopak) 

1.4.1  -  Project Manager Introduction: 

Project Manager is a Geopak tool that associates a project with its respective 
coordinate geometry job number, users, working directories and project files. Project 
Manager provides the user with an easy workflow system that keeps records of 
processes run throughout the design of a project. 

You must first setup Project Manager in order to start your project through Geopak. 
The use of Project Manager is required to create proposed cross-sections through the 
Typical Section Generator (Using X30 criteria file).  

 

It is required to use the Project Manager for all EFLHD projects working 
with MicroStation V8i and Geopak X30. 
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 Open a MicroStation design file. Invoke Project Manager by either using the 
pull-downs Applications > Geopak > Road > Project Manager  

            

 Or by using the Tools icon shown below: 
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 When Project Manager is invoked the dialog appears as shown below. The 
current directory is displayed at the top of the dialog box. Current project file is 
displayed under the Project area. Project area showing blank mean there is no 
existing projected at the displayed directory. 

                                                       

 

 

 

 

 

 

 

 

 

 

Existing Project 

file display area 

‐ Empty space 

means no existing 

project present at 

the current

Current directory 

is displayed

To navigate the current 

directory structure area 
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Project Tools  

 There are four options under the Projects pull down, New, Edit, Delete and 
Exit as shown below.  

 

 

 

 

 

 

 

 

 

 

 

 The New menu option is used to create a new project. The .prj file is stored in 
the directory shown in the Directory path at the top of the Project Manager 
Dialog box.  

 The Edit option on the pull down menu is used to change any settings 
associated with the currently selected project.     
      

 The Delete option on the pull down menu is used to delete any project that has 
been stored. The user highlights the project in the Projects list box and selects 
Delete.    

 The Exit option on the pull down menu closes the Project Manager and writes 
the settings to a resource file.  
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Directory Tools  

 There are two options under the Directory pull down, Create New Directory 
and Current Working Directory as shown.  

 

The Create New Directory option creates a new directory on your computer 
within the current directory. If the Current Working Directory option is chosen, 
the directory path in Project Manager is changed to that directory.  

Always select the Current Working Directory to access the Road 
 Project. 

 

Administration Tools  

 The Admin menu option is used to set a password on a project, if desired.  

 

 

EFLHD does not create Passwords for Project Manager projects. 

 

 

 

1.4.2 -  Create a Project 

Step I 

 EFLHD suggests to Create a Project under your current working directory. 
This is easily done by using the pull-downs on the Project Manager dialog, 
Directory > Current Working Directory as shown below: 
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 Once the Directory is set, create the New Project by using the Project 
Manager pull-downs, Projects > New as shown below:  
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 Key in the Project Name, the Project Name can be any number of 
alphanumeric characters.  

 The Working Directory specifies the location of the project data files and 
may be manually entered. In lieu of typing, the Select button may be clicked 
and the appropriate directory selected. 

Note - The Working Directory can be left blank if it is desired to have 
all of the MicroStation and GEOPAK files in a single directory 
(EFLHD’s default preference).  

 The next field is for keying in the GEOPAK (COGO) Job Number or the 
Select button may be clicked and the appropriate GEOPAK job number can 
be selected. 

Note  -  Each project should have one job number. 

If the user is creating a new project that does not have an existing .gpk file 
then the GEOPAK job number should be keyed into the Job Number field.  
This is how a new .gpk file is created within Project Manager.  If the user is 
creating a new project that has an existing .gpk file, click on the Select button 
and select the existing .gpk file.  If the existing .gpk file isn’t visible in the 
selection window then either the Working Directory is incorrect or the existing 
.gpk file is not in the Working Directory. 

Note - The Project Name specified is combined with a “.prj” extension 
to create the main Project Manager set-up file in the working 
directory. 
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Step II 

 Select the Preferences button from Create New Project Menu, the GEOPAK 
User Preference dialog box will appear as shown below:  

               

 Set the desired project related preferences. US Customary Unit specific 
preferences in EFLHD are shown in the dialog boxes below. 

 Keep the working directory and all the COGO preferences’ directory as 
blank (EFLHD’s preferred setting preference).  

Note  - This section is already discussed in Section 1.3 User 
Preferences. 

 Select OK to close the Geopak User Preferences dialog box and Create New 
Project dialog will come back again. 

                          

 Type a short Project Description in the “Create New Project” dialog box.  
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 When OK is clicked, the Project Manager dialog will appear as shown 
below, highlight the .prj file and click on OK: 

                                                           

 Step III 

Create a User 

 Once a project is highlighted and OK is selected, the Project Users dialog 
appears.     

 Select Users > New from the pull downs as shown below.. 
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 Complete the New User dialog similar to the illustration below and click on 
OK: 

                                           

 

Note – While there may be times when multiple users are required to 
work on a single project, EFLHD policy is to create and use only one 
user for one project when and NEVER use passwords in Project 
Manager.  

 

 

 

 

 

 The Project Users dialog will appear similar to the illustration shown below. 
Highlight the User and click on OK. 
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 When OK is pressed the Project Manager Road Project dialog will appear 
as shown below. Notice the Project name, the User name and Job # match 
what was previously set up. 

 

 

 

 

 

 

 

 

 

    

   

 

 

 

Project Name 

GEOPAK Job Number 

User Name
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Road Project Dialog  

 The top of the Road Project dialog box displays the Working Directory, 
Working Alignment (if defined), User and GEOPAK Job Number. In 
addition, a toggle for Working Alignment Influence Runs is also 
supported. The bottom portion of the dialog box displays the various 
processes supported during the design process. The small square in the 
upper right corner will condense the dialog box as depicted in the graphic 
below.  
 

 

 

 

 

 

 

 

                              

 

 

 

 

 

 

 

 

 

 

 

 

Click this square will 

expand/condense the 

dialog box 

File pull down menu supports Close and Exit –

Close – User is returned to the Applications dialog.

Exit – Exits Project Manager. 

User can instruct the 

software to remember the 

Project, User, or Road in 

subsequent sessions. 

Note: EFLHD prefers not to 

select any option here. 

Auto Sink option can be enabled: 

The Road Project flow chart sinks 

behind all open views when any 

tool is selected from the flow chart. 

Once the tool is closed, the Road 

Project flow chart will be brought to 

the top of the view window. 
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1.4.3 -  Create a Working Alignment 

The concept of a working alignment enables the designer to organize a project and to 
access project information without continually typing in the required information. On a 
simple project, only one working alignment may be needed.  However, on a more 
complicated project, an unlimited number of working alignments may be defined.  With 
each working alignment, the designer can define associated data. The designer can 
easily change from one working alignment to another by selecting the desired alignment 
listed in the Select dialog. Once the working alignment is selected, all previously stored 
data is utilized in subsequent processing. Three tools relating to working alignments are 
located at the top of the Road Project box:  

1) Select 
2) Define button 
3) Working Alignment Influence Runs (toggle on left side of 

dialog box) 

 Click on the Select button to create a new Working Alignment as shown 
below: 

 

 

 

 

 The Select Working Alignment dialog appears. Use the pulldowns and 
select Run > New as shown below. Click on OK. 
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 The New Run Name dialog appears. Type in the name of the “Run” to 
create. The Description field is optional. Click on OK. 

                                                          

 

 The Select Working Alignment dialog appears. Highlight the desired run 
(you may eventually have several) and click on OK. 

                                               

 

 Notice how the Project Manager (Road Project) dialog is now set to use the 
Working Alignment “INB”, as shown below: 
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 Click on the Define button. We are now ready to being “defining” everything 
about the alignment that we want to use. 

                             

 

 

 The Working Alignment Definitions dialog appears using the working 
alignment “INB”. 

 

                             

 Complete each of the required “Sections” of this dialog by clicking on each 
and completing the fields. Required sections are Plan View, Pattern, 
Shapes, Cross-Section View, and Existing Ground. 

   

 You are now ready to begin the design. 
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1.4.4 -   Project Manager Process 

 

The primary Project Manager dialog box is depicted above. The advantage of utilizing the 
Project Manager rather than selecting functions directly from the Road menu is that 
pertinent information stored within the Project Manager is automatically displayed within the 
invoked dialog box. Therefore, job numbers, chain names, stationing, file names and 
data associated with the project do not have to be typed in each time a dialog box is utilized. 
However, if the user chooses to change the fields, they have that option.  

Many of the Project Manager processes function identically to their corresponding dialog 
boxes invocation from the Road menu. However, some of the procedures invoke the Select 
Run dialog box prior to invoking the actual dialog box. The Select Run dialog box enables 
the user to set up different options to use in alternative design choices or different typicals.  
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1.5  – Create the Horizontal Alignment (GEOPAK) 
 

There are many different, and acceptable, methods of creating horizontal geometry using 
Geopak. Some are described as follow:  

1. Coordinate Geometry (COGO) 
2. Graphical COGO/Horizontal Alignment Generator (both are similar) 
3.  Store Graphics.   

 
Any of these methods are acceptable to EFLHD. Regardless of the method used, 
the final alignment must be drawn into MicroStation using the GEOPAK D&C 
Manager, with the “V8_ENGLISH.ddb” (FLH) file.  This will assure that the 
elements are drawn with the correct symbology, matching the FLH standards. 

1.5.1 -  Coordinate Geometry (COGO): 

This method allows the user to have more precise control over tangent bearings, 
control point coordinates, etc., than with Store Graphics, if done properly. But the 
disadvantages of these methods are the Commands for the command line and input 
file methods are difficult to memorize, small adjustments are hard to make, and the 
process is time consuming. 

You can create the horizontal geometry by typing commands in at the COGO 
command line, by creating an input file with a sequence of COGO commands and 
loading it into COGO, or by using the dialog box driven Store Curve from Tangents, 
Locate Traverse, etc., tools that are accessed from the COGO pull down menus to 
generate the commands.  If you use the input file method, remember that the 
COGO input file name can only be 8 characters long, must have the job number as 
the last three digits in the name, and the extension has to have an “i”+ the operator 
code.  (i.e. XXXX101.isa), where the i stands for input file. 
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1.5.1.1 -  Steps to follow to create a Chain from Point A to B as shown: 

                              
Chain from Point A to Point B 

    Y (Northing) X (Easting) 

    
TAN1 From Point(5000): 1500.000 1250.000 ---Point A 

   To Point(5001): 1500.000 1367.957    

 

 

A 

B 

Tool Bar consists of drop 

down options and icons 

COGO Key‐in: This field 

enables manual entry of 

COGO commands. 

Output Display 

Window shows the 

results generated by 

the commands. 
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CUR1 Radius=818.511 

TAN2 From Point(5002): 1770.821 1976.230  
   To Point(5003): 2212.417 2373.845  

CUR2 Radius=818.511 

TAN3 From Point: 2473.161 2854.074 (5004) 
   To Point: 2518.881  3142.737  (5005) 

CUR3 Radius=1432.394 
 

TAN4 From Point:  2668.911  3591.129  (5006) 
   To Point:  2832.335 3898.485 (5007) 

CUR4 Radius=1432.394 

TAN5 From Point:  3000.000 4570.953  (5008) 
   To Point:  3000.000  5750.000  (5009) ---Point B 

 
Step 1: Open the Coordinate Geometry dialog box by clicking on the Coordinate 
Geometry button on the Project Manager flow chart as shown: 
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You can also select the Coordinate Geometry button on the GEOPAK main dialog box. 

                                          

 

The Geopak Coordinate Geometry dialog box appears as shown below.    
                   
 

 

Note - If you are using Project Manager, the Coordinate Geometry dialog 
box will be invoked.   Otherwise, the Job Number and Operator code will 
have to be entered in the COGO Startup dialog box.  Project Name and 
Subject are optional fields.  Press the OK button to bring up the Coordinate 
Geometry window. 

Step 2: Store Points 

To store a Point, follow Element > Point > Store from the Coordinate Geometry 
dialog box. 
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 Enter Point # (start with 5000) 
 Check the Auto Increment Box 
 Enter the Northing and Easting or use the DP button to data point in your 

design file for the point data. 
 Store Point 
 Repeat until all from and to points have been stored. (ex.; You should have 

10 points, starting from 5000, 5001………5009) 
 Close the Store Point dialogue box. 

 
 

Step 3: Store Chain for Tangent line 

To store a tangent line for a Chain follow Element > Chain > Store from the 
Coordinate Geometry dialog box. 

                  

 Chain name: Tan# (Starting with Tan1) 
 Toggle Begin Station to Station As Is 
 Under Element Type select Point 
 Point Name: Type in the points between which the tangent falls. (for 

example: Tan1 lies between 5000 and 5001, so type 5000 first and hit Add, 
then type 5001 and hit Add) 

 Store Chain 
 Repeat until all tangents have been stored. (In all you should have 5 

tangents, starting from Tan1, Tan2…….Tan5) 
 Close the Store chain from Elements dialog box. 
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Step 4: Store a Curve 

To store curves follow Element > Curve > Store > By End Points from the 
Coordinate Geometry dialog box. 

                          

 Name: Cur# (Starting with CUR1) 
 Enter the PC point# (To-point of back tangent)  
 Enter the PT point# (From-point of ahead tangent) 
 Change PI Point to Radius, and enter the radius of the curve from above 

given data. 
 Choose clockwise or counterclockwise based on the direction of curve. 
 Store Curve  
 Repeat until all curves have been stored. (In all you should have 4 curves, 

starting from CUR1, CUR2…..CUR4) 
 Close the Store Curve dialog box. 

 

Step 5: Store Chain for whole Alignment 

Select Store Chain again follow Element > Chain > Store > From Element from the 
Coordinate Geometry dialog box. 

                                    

 Chain Name: RCOGO 
 Change As Is to Begin Station and enter 10+00 
 Set the Element Type (which is Point at present) to Chain and add TAN1  
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 Now set the Element Type to Curve and add CUR1 
 Continue adding all chains (tangents) and curves in the proper order. 

(TAN1, CUR1, TAN2, CUR2, ……….TAN5) 
 Store Chain 
 Close the Store Chain from Elements dialogue box. 
 Save this session. Go under File > File Utility in the Coordinate 

Geometry window. 
 Select  Save 
 Close the Coordinate Geometry window. 

 

1.5.2 -  Graphical COGO/Horizontal Alignment Generator: 

Graphical COGO and the Horizontal Alignment Generator, allow the user to create 
coordinate geometry elements, much the same as the original COGO tools, but with a 
much more graphic and user-friendly process. 

 

1.5.2.1 -  Graphical COGO: 

 Graphical COGO can be accessed by selecting: 
Applications > Geopak > Road > Geometry > Graphical Coordinate Geometry, 

     as shown below.  
 

                         

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
 

	 Page	1‐29	
 

EFLHD CADD Procedures Guide – GEOPAK V8i Edition 
Chapter 1 –          
GEOPAK V8i Basic

 

 

 Graphical COGO can also be accessed by selecting the icons from the main 
Geopak Road tool box. 

                            

 

1.5.2.2 -  Horizontal Alignment Generator: 

 

 Horizontal Alignment Generator can be accessed by selecting: 
Applications > Geopak > Road > Geometry > Layout Horizontal 
Alignments, or 

 Horizontal Alignment Generator can be accessed by selecting the icons from the 
main Geopak Road tool box. 

                        

 

 

 The Horizontal Alignment Generator can also be accessed using Project 
Manager by clicking on the Horizontal Alignment button on the flow chart.   

Note - The Graphical COGO cannot be accessed directly from 
Project  Manager. 
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 The File pull-down menu allows the user to set Preferences for how newly 
created elements will be displayed, how to name elements, and which geometry 
tables to use as a default. 

 

                               

 The User Preferences dialog is very useful.  It allows the user to preselect the 
Element symbologies for lines curves and spirals, as well as the symbology for 
the “Modify” tool.  This makes it very easy to distinguish the geometric 
components from each other while laying out the alignment.  

                                  

 

 

 

 

 

 
  

 

1) An important thing to remember is that the components never have to be 
drawn graphically in order to be manipulated later.  COGO has several  
“Visualization” options.  It is possible to simply “Temporarily Visualize” a 
component or components for manipulation or for storing the components as a 
chain.  Graphics just make the .dgn file larger and also limit you to the old 
world of single precision.  The Visualization options can be set on the COGO 
dialog box.  EFLHD recommends using “Temporary Visualization” until the 
Designer is satisfied with the alignments.  This way nothing is written to the file 
before it is desired.  

2) These symbologies are used only when the elements are NOT stored 
directly to the GPK. To store the elements as simple, graphic elements (single 
precision), the option, “Save as COGO Elements” must be checked OFF 
under the category “COGO Element Names”. 
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3)  To specify the color of these elements for storing as COGO elements 
(double precision)…. Modify the .smd file via the Geopak User Preferences, 
(Applications > Geopak > Road > User Preferences).  

 In addition you may also set up your own naming convention for storing the 
geometric components.  This is done under the Category “COGO Element 
Names”.  

Under the Category COGO Element Names, you may setup your own naming 
convention for Points, Lines, Curves and Spirals.  If the names are left blank, 
the software will default to the following naming conventions, using the “Next 
Available” name concept:  

    Points…(1,2,3…)  

    Lines… (L1, L2, L3…)  

    Curves… (C1, C2, C3…)  

    Spirals… (S1, S2, S3…)  

 

                               

One very important option on this dialog is “Save as COGO Elements”, 
(mentioned earlier).  This is what differentiates between whether the components 
will be stored as graphics (single precision) or as COGO elements (double 
precision).  To save the components directly to the GPK database and as double 
precision, make sure this option is “checked”.  

Note - The trick here is that the names you key-in will not take effect until 
this dialog is “dismissed”. 
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 Currently FLH/EFLHD is using the default Curve Design Tables setup by Bentley 
(Geopak).  

 

 Under the Category Spiral Design Tables, a set of files have been set up to 
provide the user with an easy way to add spirals (using the AASHTO minimum 
lengths) to a user defined curve radii or degree.  For example, when laying out an 
alignment with the new Geopak 2001 tools, the user simply keys-in a simple 
curve radius or degree and the spiral length values are automatically populated 
by accessing this “table” file.  

 
EFLHD uses the Spiral Design Tables. To access the Spiral Design Tables, path 
should be set to  

“M:\ Engineering_Software\Cadd_resource_v8i\X_30\Standards\Bin\english or 
metric” 

 

 

The Design Tables menu allows the user to view the settings for the current 
default design tables.  In the Design Tables pulldown, the user sets the paths 
and file names for the tables to be accessed. Once the English or Metric Spiral 
Curve table is selected, select the design speed and number of lanes.  These 
tables correspond with the AASHTO Green Book.   
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 Note - Currently EFLHD uses only the Spiral Curve tables (Metric and English).  

 Under the Category Parameter Formats, the user selects the curvature type, as 
shown below.  

                              

 Under the Category Dynamic Increments, the user selects the Increment 
adjustment Values, as shown below.  

If “checked” the option Activate PageUp/PageDown shortcut keys will allow the 
user to increment the elements during design by using the PageUp and 
PageDown keys on the keyboard.  
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 The tools menu activates the COGO tools that will be used to create geometry 
elements.  Selecting Tools > Main accesses the following tool frame. 

                           

 From the main tool frame , shown above, additional tools may be accessed from 
each of the six main tool box icons. Each of the tool boxes, as well as the tools 
from Graphical COGO, may be used together to create any combination of 
geometry, from the simplest to the most complex.  

Note - Using these tools to set a horizontal alignment, if done 
properly, is just as accurate as the traditional command line in COGO. 
This process is slower than using store graphics.  

1.5.2.3 - Examples of using the new Horizontal Alignment Generator… 

 First of all COGO must be running for this to work.  No need to worry about 
this though, because the software prompts you for a COGO session if you 
don’t already have one active. 

 

 Check your Horizontal Alignment Generator User Preferences settings as 
explained earlier to make sure that you have correctly selected all of the 
desired settings.  
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 Check to make sure that your Spiral Design Tables are pathed 
correctly.  These tables aren’t actually necessary, but make it much easier 
when using spirals and making sure that you are using the minimum spiral 
lengths for the appropriate design speed and curvature.  The path (for office 
workstations) should be set to 
M:\Engineering_Software\Cadd_resource_v8i\X_30\Standards\Bin\english.  

Browse to this directory and select the appropriate table file.                   

 

 

 

 

 

 Select the Main tool box from the Tools pulldown (as shown previously).  
 To place a typical Spiral Curve Spiral (SCS), (most common way): 

 Make sure that “Temporary Visualization” (my preference) has been selected 
in COGO.  
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 Create the entry and exit tangents, using the Store Line by 2 Points tool.  

                           

 

 

 

 

   

 Select the Place SCS (Intersecting Elements) tool.  Identify the tangents, 
(follow the on screen prompts).  Once the second tangent is identified, the 3 
elements of the SCS will appear (as keyed-in in the dialog).  To “Modify” the 
length values, you may highlight one of the length fields and use the little 
arrows for increasing or decreasing the values. Setting the Increment Values 
was explained earlier (above).  The position of the SCS can be easily warped 
into place.  When you are satisfied with the location of the SCS…simply data 
point the screen.  If you had “Save as COGO Elements” toggled ON, those 
components are now stored in the GPK database.     
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 Storing these components as a chain is much easier with Geopak V8i.  Even 
though they are not actually drawn graphically… Geopak can see them.  To 
store (for example) these 5 components as a chain, invoke the Geopak Store 
Chain tool.  

                                                     

 

 

 With Geopak V8i Store Chain there is no need to continuously click until all of 
the elements are collected.  Simply complete the dialog with the Chain Name, 
Begin Station etc… and data point any component that is visualized and 
accept it with another data point.  All adjacent components will be considered 
for the chain.  You will see several small arrows pointing in a direction.  These 
directional arrows are asking you if this is the direction that you want to store 
the chain stationing.  If this is not the direction, simply click reset and the 
directional arrows will switch… or as some in the South say….”swap”.  Once 
the arrows are pointing the right direction, data point the screen again.  The 
components are now stored as a chain.  

 

 

 

 You may have noticed that on the Store Chain dialog there is an “Opposing 
Element” option.  The options are Transpose and Create.  These options are 
given because sometimes the components may not be stored all going in the 
same direction.  When you store the chain at a direction and some of the 
components were stored in the opposing direction, you have the option to 
have Geopak Transpose those offending elements or Create new elements 
instead leaving the original ones alone…  I would recommend using 
Transpose and keep the GPK file smaller and cleaner.  The recommended 
Max Gap setting for a metric design is 0.01 and for English design is 0.03. 
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Another tool available with Geopak V8i… is the Complex Element By PI, which allows the 
Designer to place a Dynamic Alignment… This tool allows you to pre-select geometric 
values and design “on the fly”.   Give it a try.  

Under the Tasks Bar > Civil Geometry Workflows > Complex By PI. 

               

 

 

 

 

 

Enter in the desired geometry 
and dynamically place tangent / 
curve combinations. 

Change radii, lengths, curve 
types on the fly while data 
pointing to graphically create an 
alignment. 

 

 

 

         

To Modify the Visualized elements: 
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Visualized elements can be further manipulated using any of the 4 “Manipulate” tools.  

 Move Plan View Element  
 Rotate Plan View Element  
 Extend Plan View Element  
 Delete Element  

It is very important to mention that visualized elements cannot be deleted from the GPK file 
with the normal MicroStation “Delete Element” tool.   That tool only deletes elements that are 
written to the design file.   To delete these visualized elements, use the “Delete Element” tool 
on the “Manipulate” tool box.   Of course these elements can also be deleted via COGO key-
ins or COGO Navigator.  

To View the Output Listing 

 There are two ways to do this.   After the alignment is stored, activate the 
COORDINATE GEOMETRY dialog box.  

 At the top of the COGO dialog box type DES ALI [chain name].  
 This produces an output listing.  

 At the top of the COGO dialog box type DES CHA [chain name].  
 …or… use the COGO pulldowns, Element  > Chain > Describe/List/Print, select 

the chain and press Describe.  
 This produces the normal GEOPAK output listing.  

NEXT…To actually print a hard copy of this alignment, at the top of the COGO dialog box, 
type CLEAR, press ENTER, type DES ALI [chain name], press ENTER, or DES CHA [chain 
name], press ENTER, and type OUT [filename], and press ENTER.   These same 
commands are also available from the “Coordinate Geometry” dialog box “pull downs” 
located at the top of the dialog box.  

To display the alignment graphically, (for Final plans) see Display the Horizontal Alignment. 
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1.5.3 -  Store Graphics: 

The store Graphics procedure is the simplest and quickest method to create a 
horizontal alignment.  The user can use standard MicroStation draw utilities to layout 
the alignment then use the Store Graphics tool to store the alignment into COGO.  Even 
though MicroStation measurements are to single precision, GEOPAK stored elements 
are computed to double precision accuracy.  Store Graphics will make slight 
adjustments to the graphical element locations as required forcing each element in the 
chain to be exactly tangent to the immediately preceding element and the immediately 
following element.  These adjustments are always minor (e.g. the coordinates of a 
curve’s PC and/or PT may be adjusted a few millimeters to force the curve to match the 
tangents exactly) but they do occur and the user has no control over them.  However, if 
the graphical elements were drawn correctly then the chain that gets stored into the gpk 
file is exactly as “accurate” as a chain stored using any of the other methods. 

 This command cannot be accessed using Project Manager, but can be 
accessed the following two ways.  From the GEOPAK pull down menus 
select, Applications > GEOPAK > ROAD > Geometry > Store Graphics 
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Or by selecting the icons from the Geopak Road > Horizontal and Vertical 
Geometry tool box as shown below: 

 

 

 

 Selecting the Store Graphics Icon will invoke the Store Graphics Dialog 
box.  You can store the elements as Complex Chain, Selection Set or 
Single Element. 

 

 

Advantages – 

Uses simple MicroStation commands to layout alignment, adjustments 
to alignments are quick, and the only point numbers used are on the 
alignment (usually just the first and last). 

Disadvantages –  

1. Not as accurate as COGO.  Store Graphics makes minor adjustments 
to the as-drawn elements in order to get them to tie together 
mathematically. 

2. Cannot draw spirals using MicroStation commands.  If spirals are 
needed, you must use Horizontal Alignment Generator to create that 
element, and then you may continue using MicroStation commands.  
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To display the alignment graphically, (for Final plans) see Display the Horizontal 
Alignment Section 1.6.1. 

 
 

 
1.6  Display the Horizontal Alignment And Drawing Other Plan Features 
 

1.6.1 -  Display the Horizontal Alignment 

Geopak’s Design and Computation (D&C) Manager is the tool that automates the 
display the Horizontal Alignment through the use of a hierarchical database, .ddb, 
containing information about each element of the horizontal alignment display to be placed 
within a set of plans. The .ddb file in use at EFLHD can be found at: 
M:\Engineering_Software\Cadd_Resource_v8i\X_30\Standard\DDBS\English\V8_English.ddb 

 Access the D&C Manager by selecting the MicroStation pull downs:  
Applications > Geopak > Road > Design & Computation Manager as shown 
below 
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 Or can be access from the Road Tools icon as shown below:  
 

 

 

 

 

 

 

Note - The EFLHD .ddb file is already attached through project configuration 
setup. If EFLHD’s D&C Manager is not attached as shown above, then change 
it through File > Open > and select the 

M:\Engineering_Software\Cadd_resource_v8i\X_30\Standard\DDBS\English\V8
_English.ddb  

 In the “Design and Computation Manager” dialog box, Select CL Proposed 
Centerlines/Baseline as shown below:  
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 Single click on Draw Plan & Profile … as shown below:  
 
 

 

 

 

 Key in or Select the Job Number … as shown below and click on OK (in both 
dialogs):  
 

 

 

 

 

 

 

Note - This step (shown above) will not be necessary if the Project 
Manage is open. 
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Display the Chain Information: 

 Toggle “Element Type” to Chains … as shown below:  
 

 
   

 Set the Label Scale as your Plan sheet scale.  
 Select the chain you want to display with a single click shown inside the circle. 

Alignment information will display onto MicroStation file. 
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Annotate the Horizontal Alignment: 

 Again toggle “Element Type” to Stationing … as shown below:  

                       

 Set the Label Scale as your Plan sheet scale.  
 Select the chain you want to display with a single click inside the circle shown above. 

This will annotate your alignment stationing.  

1.6.2 -  Draw Widening And Other Plan View Features for X30 Criteria (Geopak) 

 

To develop roadway features representing the proposed roadway to be recognized by 
Proposed Cross Section tool as set in X30 Criteria files, two specific GEOPAK 
tools will be utilized: D&C Manager to determine element symbology and Draw 
Transition to place the elements between specific pairs of stations offsets. 

The D&C Manager is a tool that allows the user to standardize graphics elements 
(symbology) for drafting. FLH has developed a database (V8_ENGLISH.ddb) for D&C 
Manager. It is used to draw the elements which have preset standard symbology of 
the elements according to X30 criteria input file (especially for proposed cross 
section).           

The Draw Transition tool draws a line/curve based on a beginning station/offset and 
an ending station/offset relative to a selected chain. Use of this command includes 
road widening, edge of the pavement, shoulder, curb &gutter, retaining wall location, 
guardrail; curve widening, lane transitions and roadway stripping.  
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Step I 

In your “wrk” file; 

 Access the D&C Manager by selecting the MicroStation pull downs:  
Applications > Geopak > Road > Design & Computation Manager as shown 
below. 
 

                    
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Or can be access from the Road Tools icon as shown below: 
                 

 
 
 
 
 
 
Note :  The V8_ENGLISH .ddb file is  attached through project 
configuration setup. If FLH  D&C Manager is not attached as shown 
above, then change it through File > Open> and select 
the”V8_English.ddb”. 
 
 
 
 
 
 
 



 
 

	 Page	1‐48	
 

EFLHD CADD Procedures Guide – GEOPAK V8i Edition 
Chapter 1 –          
GEOPAK V8i Basic

 

 Five Categories are used to group and classify the features and items used in 
creating construction drawings. Define_dgn category is used specially for 
drawing X30 Criteria elements. This category contains two sub-categories: 
Proposed and Existing category. The sub-categories break down each 
classification into more specific items, such as Widening, Plan View Overrides, 
etc are the subcategories of Proposed category. Within a category, the 
individual items that are included are designated according to the process that 
they will be used for. This hierarchical data structure functions much like a 
directory. Double clicking enables the user to move up or down within the 
database as shown below.   

 

 In the “Design and Computation Manager” dialog box as shown above, 
Select Prop. Edge Widened Shape (same cross slope as shape). The 
second dialog box appears as shown below: 

  

 Select Place Influence option as shown above.   
   

When the Place Influence toggle is activated, elements are drawn using the 
level, symbology and attributes as defined in the GEOPAK database. 
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Step II 

 To invoke the Draw Transition dialog, select Application > GEOPAK > 
Road > Plans Preparation > Draw Transition or select its icon from the 
GEOPAK Road tool palette as shown below. 

 

 

 

 

 

 

 The Draw Transition dialog is shown below. 
 
 

 

                                  

 Fill in the Draw Transition dialog with the information for the transition. This 
includes the Job number, the reference Chain, the desired Beginning 
Station, Beginning Offset, and Ending Station and Ending Offset then 
click Draw. This will draw the elements you have selected in the D&C 
Manager. 

 
 

 
To draw another element, select the element in D&C Manager and fill the 
Draw Transition dialog for Beginning Station, Beginning Offset, and Ending 
Station and Ending Offset as required for the specific element and then click 
again Draw. 
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Draw Transition utilizes standard surveying convention for 
offsets. A positive offset (i.e., 55.0) would be to the right, while a 
negative offset (i.e., -55.0) would be to the left, of the chain. 
Orientation is according to the direction of stationing. 

 

1.7 -   Create/Draw Existing Ground Profile (Geopak) 

 

There are two methods available for creating and storing an Existing Ground Profile; 
Traditional Method and a Draw Profile Tool Method. Any of these methods are 
acceptable to EFLHD. Regardless of the method used, the final alignment must be drawn 
into MicroStation using the “V8_ENGLISH.ddb” D&C Manager file.  This will assure that 
the elements are drawn with the correct symbology, matching the FLH standards. 
EFLHD’s preferred method i.e. Draw Profile Tool Method is explained in the 
following section.   

 

1.7.1 -  Draw Profile Tool Method (EFLHD Preferred Method): 

The Draw Profile Tool Method allows for not only storing the ground profile into COGO, 
but also the ability to draw it (graphically) without actually going into the Design and 
Computation Manager  directly.  
You must have a horizontal alignment (Chain) stored in COGO and a  .TIN file.  

 
 Create a new DGN file for the Profiles using “Sur_ft2D.dgn” seed file.  

 Rename this file according to the EFLHD Naming Convention (e.g. 01-lop10(2)_pro.dgn).  

  Open a MicroStation  design file and invoke the Draw Profiles tool via the pulldowns, 
(as shown below):  

 Applications > Geopak > Road > Plans Preparation > Draw Profiles  
 … or use the Draw Profiles icon, (as shown below):  
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 When the dialog box (below) appears, Select the Job Number and Chain. You’ll 
notice that unless you already have a profile cell placed in the design file, all fields 
will be ghosted out except for the 2 icons to the right of the Job Number and Chain 
fields. You must place a profile cell before you can create a profile.  

 

                                           

1.7.1.1 - Create Profile Cell 

 Click on the Dialog Profile Cell Control icon as shown below: 
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 The Profile Cell Control dialog appears as shown below. Click on Place Profile Cell: 

                     

 The Place Profile Cell dialog appears (shown below) along with the Profile Cell 
attached to your cursor awaiting placement.  

 The beginning Station should populate automatically. The Horizontal and Vertical 
scales are normally set as shown below for 10H and 1V scale with No Gap. The Top 
Elevation and Bottom Elevation of Cell Range are set according to profile 
minimum or maximum elevation range.  

 

< Origin Elevation of the Profile cell  
 

 

<Elevation range can be gotten from the 
contour lines elevations. 

 

 Once the dialog is completed, data point in your design file somewhere where the 
profile cell won’t interfere with other previously drawn graphics.                                           

 

Note - The profile cell origin should look similar to the graphic shown above. 
The profile cell text parameters are set by the active MicroStation text 
settings. 

 Close the Profile Cell Control dialog box. 
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1.7.1.2 - The “Surfaces” Tab:  

The Surface tab defines the surfaces utilized as source data when drawing  profiles. 
Multiple surfaces from a variety of sources can be drawn in a single processing. Each 
surface to  be drawn must be added to the list box. 

 Select the Surface tab in Draw Profile dialog box after the Profile Cell is established, 
the dialog box dynamically changes as shown below. 

                

 

 Select Label Scale according to the Plan sheet scale for the texts size (e.g. 100 for 
100 scale Plan Sheets).  

 On the Surfaces tab as shown above, select the folder icon in the Details area, and 
then select the .TIN file to cut the profile. Set the Method to Triangles (This instructs 
the software to compute elevations at each location that the chain intersects a 
triangle leg from the TIN). 
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 Use By Feature mode in the Display Setting area of the dialog box. Click the 
paintbrush icon and select the item “EXPROF Existing ground Profile”from the 
D&C Manager .  

 

                    

 

 

 

 

 

 

 

 

 

 

 Press OK. 
 Click the Add Surface Settings icon to add the profile to the list box as well as draw 

the profile into the MicroStation file. 
 

                                                 

 

 The final setting on Draw Profile for Surface tab is as shown below. The 
recommended Filter Tolerances in EFL should be left at the default values of 
Horizontal=0.30 and Variance=0.10. 
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Note - Use the following icon as shown below to store an Existing Profile in 
COGO, though it is not required to display into your MicroStation  file in 
EFLHD. 

                

 Software now will display your Existing Profile in your design file. 
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1.8 - Create Proposed Vertical Alignment (Geopak) 

There are two ways to create proposed Vertical Alignment graphically.    
   

1.8.1 - The “VPI Based” Profile Design Tool: 

 Select the Vertical Alignment button on the Project Manager dialog box as shown 
below: 
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Or 

Select APPLICATIONS > GEOPAK > ROAD > GEOMETRY > LAYOUT PROFILES 
(VPI Based) or from the Road Tools icon as shown below: 

                        

 Most likely… if you’re at this point in your design, you have already extracted a 
ground profile and have it displayed graphically.  Click on Identify Cell, data point the 
cell, click on OK.  
   

 This will invoke the GEOPAK Profile Generator as shown below:  
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 From the pull down menu, select File > Preferences….   This invokes the 
Preferences dialog as shown below:  

 

This is where you set the preferences for dynamically laying out the profile. User 
has the option of selecting Maintain K Value or Maintain Curve Length.   We 
typically select Maintain Curve Length.   When finished, click on OK.  

 From the pulldown menu, select File > K-Values Table. This invokes the K-Values 
Table dialog as shown below:  
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 Using the File pulldown, select File > Open and browse to the folder  
M:\Engineering_Software\ Cadd_resource_v8i\X_30\Standards\Bin\english\ and 
select the appropriate K-Value table.  Press Open as shown below. Press OK on K 
Values dialog. 

 

 

 

 

 

 

 

 

 

 

 The GEOPAK Profile Generator is shown below (with the K-Value table 
“Kvalues_2004english.kvl” selected):  

 

 To begin using the GEOPAK Profile Generator, click on Dynamic and snap to the 
beginning of where you want the profile to start.   This would usually be exactly at the 
beginning of the existing ground profile.   Accept the snap with a data point of the 
mouse.  
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 Pan on ahead, click on Insert After and data point the screen where the next VPI 
should be.   I would suggest laying out all the VPIs first, save the file, using the 
pulldown, File > Save As and then go through designing the vertical curves.   The 
vertical curves can be entered by typing in the length in the field, or simply selecting 
the design speed on the GEOPAK Profile Generator.  

 When finished, save the file again.   The vertical alignment can now be reviewed 
using COGO by using the COGO pulldowns Element > Profile > Print.   Select the 
Profile and click on Apply.  

 

1.8.1.1 - Reload/Modify the Profile: 

 Select the Vertical Alignment button on the Project Manager dialog box (as shown 
in Section 1.8.1). 

 Click on Identify Cell, data point the cell, click on OK (as explained in Section 1.8.1).  
 

 This will invoke the GEOPAK Profile Generator. Select File > Load Profile on 
Profile Generator dialog box as shown below.            

  

 

 Click on Select and pick the Profile.   
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 Click OK will load the Profile Generator with profile data for edit as shown below. 

 

  Click on Next VPI to move to the VPI to be adjusted or use the horizontal slide 
bar.   When the little reference circle is on the VPI to be adjusted, click on Dynamic 
and slowly move the cursor into the circle.   Nothing will happen until the cursor gets 
close to the reference circle.   You may then modify the profile dynamically.   When 
finished modifying, (make sure Redefinition of Elements is On in the COGO dialog 
box and save the file again. VPIs can also be inserted or deleted, dynamically.  

1.8.2 - Display Proposed Profile: 

Use the Draw Profile Tool setup to display Proposed Profile.  

 
  Open a MicroStation  design file and invoke the Draw Profiles tool via the pulldowns, 

(as shown below):  
 Applications > Geopak Road > Plans Preparartion > Draw Profiles  
 … or use the Draw Profiles icon, (as shown below):  
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 Draw Profile dialog box appears as shown below.  

 

 Select the COGO tab.   

1.8.2.1 - The “COGO” Tab:  

The COGO tab is utilized for drawing any profile that has been previously stored into 
the gpk file. The functionality of the remainder of the dialog is very similar to the 
Surfaces tab.  
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 Select the COGO tab in                                                                                                       
Draw Profile dialog box,                                                                                                           
the dialog box dynamically                                                                                                     
changes as shown.  

 

 

 

 

 

 

                                 

 Select the Profile Name to be drawn in Details section of the icon. Keep the 
Vertical Offset defaults to a value of 0. Station Limits may also be specified to have 
the software draw only a portion of the profile. 

 Use By Feature mode in the Display Setting area of the dialog box. Click the 
paintbrush icon and select the item “DPROF Design profile”from the D&C 
Manager.  
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 Press OK. 
 Click the Add COGO profile Setting icon to draw the profile into the MicroStation 

file as shown below. 

                                                 

 

 Software will display your Proposed and Existing Profile in the MicroStation file. 
 

 

 

 

 

 

 

Add COGO Profile Settings



 
 

	 Page	1‐65	
 

EFLHD CADD Procedures Guide – GEOPAK V8i Edition 
Chapter 1 –          
GEOPAK V8i Basic

 

1.8.3 -  To print a Vertical Profile Output file: 

 Open COGO 
 Use pull downs, select Element > Profile > Utility 
 Select Profile (e.g. PROSPR) to be printed as shown below. 

 

                                                    

 

 Select Print icon as shown above. The Coordinate Geometry dialog box will display 
the Profile data as shown below. 
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 Type ‘Out PRORAMP (File name, max. 8 character) in COGO Key-in and Enter, as 
shown below. 

 

 

 

 GEOPAK COGO will create an output file for the proposed data file PRORAMP.osb 
in working directory.  Where 228 is the Job number and osb stands for Output for 
User SB for this project. 
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1.9 - Existing Ground Cross Sections (Geopak) 

 

1.9.1 - Draw Pattern Lines (Geopak) 

 

The project designer shall create a design file containing the pattern lines representing 
the locations of all cross sections in the process of generating the existing and 
proposed cross sections, earthwork etc. The pattern lines for each alignment, along 
which original ground cross sections are derived, shall be distinguished by the pattern 
lines layer name P_GPK_Pattern_01, P_GPK_Pattern_02 …, etc in EFLHD.  
 

 

 Create a new dgn file (give the name e.g. 01-xxxx_wrk.dgn) and reference your 
dgn file that contains your chain to this file just to be able to see position of the 
chain.  

 Select the Draw Pattern button from the Project Manager dialog box as shown 
below: 

                  

 

 Create a new run for your patterns or use the default untitled run. 
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 The Draw Pattern Lines dialog appears as shown below:  

 

 This application will simply draw normal MicroStation line elements 
perpendicular to your chain at user specified increments, station ranges, 
and widths and at user specified Level Symbology. To select the Level 
Symbology, double click in the rectangle to the right of Level Symbology 
at the bottom of the dialog.  

 The Geopak Set Feature dialog appears as shown below:  

                                   

 Complete the Geopak Set Feature dialog settings as desired and press OK. 

Note – The Color, Style and Weight of the feature settings should be set to 
ByLevel. 

 Complete the Draw Pattern Lines dialog settings as desired and press Draw 
Pattern Lines.   You should now have a series of lines perpendicular to your 
referenced chain.   Later, we will use these lines to generate existing ground cross 
sections from the “TIN” file.  
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1.9.2 -  Generating the Existing Ground Cross Sections (Geopak) 
 

First of all the designer must have the following: 

1) A .TIN file.  
2) A .dgn file containing your “pattern lines”. (explained in Section 

1.9.1)  
3) A horizontal alignment stored in COGO. (explained in Section 1.5)  
4) A .dgn file to create your “existing ground cross sections”.  

 Create a new dgn file(give the name e.g. 01-xxxx_Dxs.dgn). The existing 
ground cross sections will be drawn in this dgn file.   
       

 Select the Existing Ground Cross Sections button from the Project 
Manager dialog box as shown below: 
 

 

                      

 Create a new run for your existing ground cross sections or use the 
default untitled run. 
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 The Draw Cross Sections dialog will appear as shown below:  

 

 Select the “XS Cells” Tab: Here the designer tells Geopak where to find the 
information to create the cross section cells and how they are to be laid out.  

 Select “By DGN File” method for the selection of the Pattern.  

 Toggle on the desired element parameter, (i.e.. Level, Weight…)  the press 
the Select button.  The Mask dialog is displayed, wherein the desired 
parameter settings may be identified.  You may select as few or as many 
parameters to identify the desired pattern lines or line strings. Or use the match 
button to select the element parameters. 
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 Select Levels “P_GPK_Pattern_01” (Or select the levels created during the 
Draw Pattern procedures). 

 

 

 Select Scale to 10 and 10 as a standard practice in EFLHD. And keep all the 
setting for spacing as default as shown above. 

 Select the Surface tab in Draw Cross Section dialog box, the dialog box 
dynamically changes as shown below (The user creates ground cross sections 
from a TIN file through this tab). 
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 Select the folder icon in the Details area, and then select the .TIN file to draw 
the cross section. Set the Method to Triangles (This instructs the software to 
compute elevations at each location that the pattern lines intersect a triangle 
leg from the TIN) and select Type to Line. 

Note - For several reasons, these elements should be drawn as lines 
not line strings. 

 Use By Feature mode in the Display Setting area of the dialog box. Click the 
paintbrush icon and select the item “Exist Ground in XS”from the D&C 
Manager as shown below.  

 

 

 

                    

 

 

 

 

 

 

 Press OK. 
 Recommended Filter Toleraces at EFLHD are shown below: 

 Metric tolerances are .03 and .009  
 US Customary tolerances are 0.10 and 0.03 (as shown below):  
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 Click the Add Surface Setting icon to add the surface to the list. 
(Delete any incorrect surfaces) 
   

                                                 

 Click on the Draw button located in the upper right corner of the dialog to draw 
the existing cross section in the design file. 
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1.10 - Developing the “Superelevation” Shape (Geopak) 

 

A graphical representation of the superelevation  transition breaks can be produced in the 
form of MicroStation complex shapes. These complex shapes are plotted in a design file 
and read when running Templates to produce the Proposed Cross sections. 
 The user fills out several dialog boxes in order to create an ASCII input file.   When this 
input file is executed, the results are graphical elements representing the lane widths and 
superelevation cross slopes.   I would describe these graphical elements as intelligent 2D 
elements.  

The Designer must have a horizontal alignment stored in COGO, a proposed profile 
stored in COGO, and a dgn file to create a complex Geopak Shape.  

 

 Open the design file(01-xxxx_wrk.dgn) that you created for Pattern lines (See Section 
5.9.1). You will draw Shapes for Superelevation in this design file. 

 Select the Calculate Superelevation button from the Project Manager dialog box 
as shown below: 
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 The Select Run dialog appears. Use the pulldowns and select Run > New 
as shown below. Click on OK. 

 

 The New Run Name dialog appears. Type in the name of the “Run” to 
create. The Description field is optional. Click on OK. 

 

 The Select Run dialog appears. Highlight the desired run (you may 
eventually have several) and click on OK. 
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The Automated Superelevation dialog will appear as shown below:  

 

 Set the directory for Superelevation Preferences by using the pulldowns 
File > Directories as as shown below: 

                                          

 Click on Default All (as shown below) and all directories will be set as shown 
below. The example below illustrates the English directory paths.  

Note - For Metric, the path is 
M:\Engineering_Software\Cadd_Resource_V8i\X_30\Standards\Bin\Metric. 
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 Click on Symbologies to set the element symbology for the Auto Shapes.  It 
is recommended to use P_RDW_Super_Shapes for the shapes as shown 
below.  

                                                  

                                               

 

 The Superelevation Preferences (file) can be selected it from the 
Automated Superelevation dialog as shown below:  

                            

Note - AASHTO 2004 recommended that the proportion of runoff 
length on the tangent range from 60 to 90 percent for all speeds. 
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FLH has selected options within the range of AASHTO 2004 
recommendation. Typical preference is set 67% and developed three 
sets of preferences 67-33, 70-30 and 80-20 for transition distribution 
as shown above.         
 Explanations of this can be found on page 175 on page 182 in 
AASHTO 2004.  

 The next step is to simply tell Geopak a little more about your 
design.  Complete the top portion of the Automated Superelevation dialog:  

 

 

 Select the GPK file  
 Identify the Chain  
 Key-in the Design Speed  
 Select the Superelevation Preference file   
 Select the maximum “e” value  
 Select from the toggle Divided or Undivided.  We typically design 2 lane 

roads, so select Undivided.  
 The L Selection is made for you.  It’s tied to the Superelevation Preference file 

selection.  
 Select the Profile.  Click on both the Left and Right Tabs to make sure that the 

Profile has been selected for both.  
 For most cases, set the Tie option to Offset and the Offset data field to 0.00.  
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 Select Quick Entry for your shapes as shown below:  

                                                           

 The  Quick Entry tool allows the user to enter the data for both the left and 
right shapes simultaneously… however the Dependency must be changed 
manually if one is desired to be Independent.  

 Enter the values in the data fields and press OK.  

                                       

 The result is shown below:  
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 As mentioned earlier… as a result of using the  Quick Entry tool, the Right shape 
will also be set to Dependent.  To change the right shape to be Independent, simply 
click on the Right tab and uncheck the Dependent box (as shown below).  I normally 
create one side Dependent and the other Independent simply so that they are 
automatically drawn in different colors, (see Symbology pull down explained 
previously).  Both sides can actually be Dependent, but they both cannot be 
Independent.  

                                  

 

Note - Remember, all of this is done to simply create an ASCII input file, 
(which can be edited).   

 Now fill the Input File name and click on Generate Superelevation Transitions 
(This file will be created and placed in your working directory).  

 When the input file is created the Geopak Text Editor will automatically pop up 
as shown below.  Click on the icon at the far right (Create Superelevation 
Shapes) to process the file.    

                   

 

 Once pressed the “Create Superelevation Shape”, the superelevation shapes will 
be drawn into the MicroStation design file. 
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IMPORTANT:  You should always review the input file for how the 
shapes have been calculated and drawn, before proceeding any farther 
with your design. You may also edit this file according to your project 
requirement. 
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1.11 - Proposed Cross Section (Geopak) 

 Open the design file (01-xxxx_Dxs.dgn) which was created for the Existing cross 
section (Section 5.9.2). The Proposed Cross section will be developed on the top of 
Existing Cross Section. 

 Open Project manager and put a check mark in the white box for Working 
Alignment Influence Runs as shown below: 

                          

   Note - Making sure the working alignment is defined. 

 Select the Proposed Cross Section button from the Project Manager dialog box as 
shown below: 
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 The Select Run dialog appears. Use the pulldowns and select Run > New 
as shown below. Click on OK. 

                                                      

 The New Run Name dialog appears. Key in the name of the “Run”. The 
Description field is optional. Click on OK. 

                                    

 The Select Run dialog appears. Highlight the Run and click on OK as 
shown below:                                     
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 The Proposed Cross Sections dialog appears. Notice that the name of the 
Run (in this case Run_1) also appears at the top of the dialog as shown 
below: 

                                           

 Click on XS DGN File and browse to the cross section DGN file. Adjust the 
Tolerance setting as described below: 

                                   

The “Tolerance” setting is very                             
  important. 

US Customary projects, 
Tolerance = 0.01. 

Metric projects,                   
 Tolerance = 0.003 

 

 Click on Pattern and put a check in the white box for Use Working 
Alignment. Since your pattern lines have been previously defined in your 
working alignment “INB”, there is no need to identify them again. 
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 Click on Existing Ground and put a check in the white box for Use Working 
Alignment. Since your Existing Ground has been previously defined in your 
working alignment “spr”, there is no need to identify it again. 

                                   

 Click on Shapes. This Typical Section requires superelevation shapes. 
Put a check in the white box for Use Working Alignment.  
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 Click on Shape Clusters. Initially the dialog appears as shown below, 
basically blank with many of the option buttons ghosted out: 

                                

 Click on the Scan button and the List of Clusters dialog appears as shown 
below. Highlight the shape cluster: 
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 Click on the Add button as shown below: 

 

 When the Add button is pressed the shape cluster information gets added to the 
collection window. Highlight the information in the collection window.The 
Typical button becomes unghosted. Click on the Typical button as shown 
below:  
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 The Typical Sections dialog appears as shown below. Select the desired 
Typical Section.  

 

Note - Note the Description button located on the right side of the 
dialog. When pressed, this invokes a file that provides detailed 
information on how the typical works including detailed 
drawings. 

 For this example we are using Undivided New Construction, so select 
UNPAVT. 

You may apply this Typical Section to the Whole Chain or a Station Range. 
When Apply to Station Range is selected, be sure to include the region 
numbers, as shown below (r 1). 
 
Note - Do not check the white “On” Chain box. Chances are you will 
never use this option. 
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 Select Apply at the bottom of the dialog. 
Each Typical Section is associated 
with different combinations of criteria 
files. 
 
When Apply is pressed, the user 
is basically instructing the software 
what criteria files to use (and where) 

     and populates the Proposed Cross 
     Sections dialog as shown below: 

 
 
 
 
 
 
 
 
 
 
 
 
 

Click on Define DGN Variables. You can ignore this portion of the 
Proposed Cross Sections dialog as it only applies to the 
Automated Cross Section Labeling Typical. 
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 Click on Define Variables. This portion of the dialog is where you specify 
“Global” variables such as the name of your mapping file where all the 
existing features are drawn (existing fence, existing edge of pavement…....). 
You must also specify the names of all other DGN files where the software is 
supposed to look for plan view elements, such as proposed widening lines, 
or proposed guardrail. 

- Highlight the Variable, (such as CROSS SECTION DGN), by clicking in 
the white area.  

- Once highlighted, the default value will populate the Value field.  

- Key-in the Value and press Modify.  

                         

 Click on Redefinable Variables. This portion of the dialog is where the user 
can set project specific values for their design. 

 In the example below, the 1st Surfacing Layer variable 
(_d_SurfacingLayer1Thickness) needed to be modified. The Variable was 
highlighted and the Edit button was pressed. When Edit was pressed the 
Redefinable Variables Editor dialog was invoked. The default value was 
changed to 3/12 for surface layer thickness. 
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 The Save button was pressed. 

               

 

 

 

 

 

 

 
Note - See Appendix-A for more help 
on Editing Redefinable Variables. 

 

 

 

 Click on Plot Parameters. Uncheck all Plot options as shown below: 
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 Drainage is not used in Eastern Federal Lands.    
     

 When all modifications are completed, save the Run settings using the 
pulldown Files > Save Settings as shown below: 

                                          

 To execute the Proposed Cross Section Run, use the pulldown Files > Run as 
shown below: 
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 The dialog below will appear. Set the dialog to To Screen or to create a .log file by 
selecting To Log File. Check Pause On Each Section and press Apply. 

                                  

 After the first cross section is plotted, you may uncheck the Pause on Each Section 
toggle and press Apply again to complete the run. 

 

1.11.1 -  Save Backup of Proposed Cross Section Run as an ASCII Input File 
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1.12 -  Draw Construction Limits (Geopak) 
 

This will draw the graphical elements representing the top of cut and toe of fill on the Plan 
view. 
First of all the designer needs to have a cross section file (e.g. 01-xxxx_Dxs.dgn) 
containing existing ground and proposed elements,( i.e. top of pavement, ditch, cut and fill 
slopes etc.) and a design file(e.g. 01-xxxx_des.dgn) for displaying construction limits 
graphically. 

 
  

 Open a design file (01-xxxx_Dxs.dgn) containing your Existing and Proposed Cross 
Sections.  

 Open Project manager and Select the Limits of Construction button from the 
Project Manager dialog box as shown below: 
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 The Select Run dialog appears. Use the pulldowns and select Run > New as shown 
below. Click on OK. 

                                                      

 The New Run Name dialog appears. Type in the name of the “Run” to create. The 
Description field is optional. Click on OK. 

                                                          

 The Select Run dialog appears. Highlight the desired run and click on OK. 
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 The Limit of Construction dialog appears as shown below:  

                                             

 Key in all appropriate data.   The Plan Dgn (e.g. 01-xxxx_des.dgn) field is the name 
of the .DGN file that you want the construction limits elements to be drawn into. Set 
the Tolerance to 0.03. 

 

 The Plot Parameters button, when pushed, brings up the Plot Parameters for 
Construction Limits dialog.                                       

                            

 

Note - These construction limit lines should match the weights 
and line styles shown on the “Conventional Symbols and 
Abbreviations” sheet shown in your plans. 
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The EFLHD CADD standards call for these lines to be drawn on Level 
name P_RDW_Slope_Stake_Limits. 

      

 Cut Line… color 2, weight 3, line style 1,  

 Fill Line…color 2, weight 3, line style 3  

 Transition Line…color 2, weight 1, line style 4,  

 

 An option is the “Place Construction Limit” in the Plot Parameters for Construction 
Limits dialog.   When this is toggled on, text may also be drawn in the Plan dgn file 
(not commonly used in EFLHD).  

 When finished keying in your Plot Parameters for Construction Limits, press 
OK.   After double checking all the fields in the “Limit of Construction” dialog press 
APPLY. 

If everything was successful, you can open the Plan Dgn (e.g. 01-xxxx_des.dgn) file 
that you selected and see your construction limits. 
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1.13 -  Earthwork Quantities (Geopak)   
 

FLH has created a seed earthwork run that is in sync with the .x30 criteria. The actual file 
is located on the server under 
M:\Engineering_Software\Cadd_Resource_V8i\X_30\Standards\Seed_runs\projdbs\user\. 
The name of the file is FLH.004 

 

Follow the steps below to use the seed earthwork run 

 In Windows Explorer, navigate to 
M:\Engineering_Software\Cadd_resource_v8i\X_30\Standards.                                      
Copy the Seed_runs folder and its contents to your Desktop. 

 Open a cross section dgn file (01-xxxx_Dxs.dgn) that contains your proposed Cross 
sections elements. 

 Open Project manager and put a check mark in the white box for Working 
Alignment Influence Runs as shown below: 

                          

 Select the Earthwork button from the Project Manager dialog box as shown below: 
                  

 

 



 
 

	 Page	1‐99	
 

EFLHD CADD Procedures Guide – GEOPAK V8i Edition 
Chapter 1 –          
GEOPAK V8i Basic

 

 

 

 Select Run > Copy > Project from the pulldowns, as shown below:  

                                  

 Using the Browse capabilities of the Directories portion of the dialog, double click 
your way to the folder C:\Users\Your.Name\Desktop\Seed_Runs\, as shown below. 
Double-Click the FLH.prj to select it.  
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 Select [user] and press OK, as shown below:  
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 Select earthwk and press OK, as shown below:  

 

 Type in a Run Name that fits your project and an optional Description. Press OK, as 
shown below:  

                                   

 

 Select your earthwork run and press OK, as shown below. Be patient, as it may take 
30 seconds or so to copy the run from the server:  
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 The Project Manager Earthwork dialog will appear, as shown below. Notice the 
name of the run is shown in the blue title bar:  

                                   

 Click on the XS DGN File category on the left side of the dialog and click on the 
Select button to select your cross section file.  

 Adjust the Tolerance to one of settings shown below.  
o Metric projects should have a Tolerance setting of 0.001  
o US Customary projects should have a Tolerance setting of 0.03  

 

 
 

 Selecting the XS DGN File and setting the Tolerance setting are the only mandatory 
adjustments that need to be made to this run.  

 Other categories (such as Centroid Adj) can be adjusted to suit your project as 
desired.  

 When all adjustments are complete, save the run by using the pulldowns File > Save 
Settings, as shown below:  
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 To process the earthwork run, select Run from the pulldowns File > Run, as shown 
below:  

 

 

 The Earthwork dialog will appear as shown below. Set the dialog to To Log File, type 
in a name for your earthwork report, toggle Pause On Each Section to ON (if you 
want the run to stop on each xs for review) and press Apply.  

 

 After checking your first cross section, toggle Pause On Each Section to OFF and 
press Continue as shown below:  
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 The earthwork report can be reviewed using any ASCII text editor.  
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 The documentation below is simply for illustration on how Geopak interprets the various 
elements drawn in a cross section file. The examples below do not reflect the current levels 
or colors used with V8i.  

 

 

Below is what the output file would look like. 

 
             Material Name    End Areas  Unadjusted Adjusted   Mult   Mass 
Station                                  Volumes    Volumes   Factor 
Ordinate 
                              (square    (cubic     (cubic                    
                               yards)     yards)     yards)                  
----------- ---------------- ---------- ---------- ---------- ------ ------
-- 
12+160.00   ITEM_NO._20401__ROADWAY_EXCAVATION 
                Common Exc       0.00          0          0   1.00 
              Subgrade Exc       0.15          4          4   1.00 
               Subsoil Exc       0.00          0          0   1.00 
                    Fill         0.00          0          0   1.00        4 
            ITEM_NO._20801__STRUCTURE_EXCAVATION 
                Common Exc       0.66          7          7   1.00 
              Subgrade Exc       4.26         43         43   1.00 
               Subsoil Exc       0.00          0          0   1.00 
                    Fill         0.00          0          0   1.00        4 
                Mass ordinate for ITEM_NO._20801__STRUCTURE_EXCAVATION = 49 
            SUITABLE 
                Common Exc       0.00          0          0   1.00 
              Subgrade Exc       0.00          0          0   1.00 
               Subsoil Exc       0.00          0          0   1.00 
                    Fill         1.22         87         87   1.00      -83 
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      ITEM_NO._40101__HOT_ACP 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         0.54         11          0   0.00      -83 
            ITEM_NO._30201__EMULSIFIED_BASE_GR_D 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         0.43          9          0   0.00      -83 
            ITEM_NO._30101__AGGREGATE_BASE_GR_D 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         1.10         22          0   0.00      -83 
            ITEM_NO._20407_SELECT_TOPPING 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         2.33         47          0   0.00      -83 
            ITEM_NO._25103__KEYED_RIPRAP 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         3.85         39          0   0.00      -83 
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1.14  -  Reports (Geopak) 
 

GEOPAK uses the proposed cross section files to produce staking reports in EFLHD 
format.  The creation of these will be required on all EFLHD projects that have cross 
sections.  These reports include the Subgrade Template Report, the Staking Details 
Report and the Blue Top Report. 
  
With the development of FLH standard files and the x30 criteria, Central Federal Lands 
has developed a Microsoft Visual Basic Application (MVBA) to generate a Subgrade 
Template Report. This cross section report replaces the previously generated FHWA 
Slope Stake Report and the Red Top Report. 
 
GEOPAK progresses from left to right across each cross section while preparing each 
report. The user will need to provide the level symbology of the existing ground and all 
the proposed elements to be reported on.  These reports will be placed in ASCII files for 
ease of printing and electronic transfer. 
 
The following sections will describe the processes used to create each of the reports. 

 

 

1.14.1 -  Subgrade Template Report: 

 
The Subgrade Template Report includes the red top (Subgrade) stake locations plus 
points at all breaks in the roadway prism cross-section (i.e. ditch lines, hinge points, 
curb lines, sidewalks, benches, walls, etc.), plus the slope sake catch point and the 
reference hub point.  
The Subgrade Template Report MVBA evaluates text elements within GEOPAK cross 
sections and produces a report based on the text elements found that match the user-
specified search criteria. 
The Subgrade Template Report provides a better format for presenting staking data to 
contractors, is easier to understand, provides ease for quality control check, and 
allows for unlimited number of template points.  
Subgrade Template Point Identification Sheets were developed to help clarify the 
information contained in the Subgrade Template Reports. Subgrade Template Point 
Identification Sheets are used to identify template points along each typical cross 
section. These Sheets can be access on 
“M:\Engineering_Software\Cadd_resource_v8i\Standard_Shts\SG_Template\ 
subgrade_template.dgn” directory. 

 
 Open the cross section dgn file (01-xxxx_Dxs.dgn) that contains your existing and 

proposed Cross sections. 
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 Select the Plan View Design button from the Project Manager dialog box as shown 
below: 

 

 

                  

 The following dialog box will appear. Select the Design and Computation Manager 
Icon.  

 

                                                     
 

Note - D&C Manager can also be accessed through Applications > 
GEOPAK > ROAD > Design & Computation Manager or from the Main 
Geopak Road Tools dialog box. Any method can be used to activate the 
D& C Manager, but make sure the project manager dialog is activated prior 
to accessing the Subgrade Template Report MVBA; this will allow the 
MVBA to access project related settings. 
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 Select the CFL Subgrade Template Report from the MVBA Applications 
category in the V8_English.ddb (D&C Manager) as shown below.  

 
                                  

 
 

 
 Double click the Subgrade Template Report. The Subgrade Template Report 

dialog box will appear as shown below.  
                                

                                   
 

Note:-The Subgrade Template Report MVBA has three tabs which must 
be filled in prior to generating the Subgrade Template Report. The first 
tab entitled “General” contains general information including, Job #, 
Chain, Begin and End Station and the headers for the report.  
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 Enter the project information as shown above. Toggle on Write Subgrade Trace 
Elements, while the report is generated, a trace line is drawn to spot check the 
text points selected for the report. The trace line is drawn to a level named 
X_P_Subgrade_Trace. The trace line can be visually reviewed to ensure the 
correct path was used.  

 
 

 Select “Search Symb” tab. Under this tab, symbologies for Text, Existing Ground, 
and Proposed Grade needs to be defined. Symbology can be defined by 
matching or by selecting levels, colors, weights and styles.  

 

                                                        
 
 

Note - When the Subgrade Template Report MVBA is invoked, the VBA 
loads a default Subgrade Template Settings (.sts) file and automatically 
places it into the working directory. The default Subgrade Template 
Settings (.sts) file contains all the settings of the Search symb tab  and 
the Search Text tab according to FLH Template setup.The user can 
modify the settings as appropriate for their project and save this file or 
rename the file and save it to the Working Directory. 
 
  

 Select the “Search Text” tab. Identify all the text to search for in the cross 
sections that define the path along the subgrade to generate the report. The 
default Subgrade Template Settings (.sts) file contains the text to generate report 
for a standard project. Modify, delete or add text values based on the typical 
section of your project. Use the Subgrade Template Point Identification Sheets as 
a guide in identifying text points.  
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 When the Reference hub cells have been used and found, the report will use 

“Refhub” to label the point in the report. Any cell with the name “ REFHUB” found 
in the cross section and lying on the existing ground will be listed in thereport. 

 
Reference Hub is not used in any of the EFLHD project for the staking 
purposes.  
 

 Select the “Search Text” tab. Select the level X_Text_Search, 
X_Text_Wall_Points and X_Text_Subgrade, associated colors, weights and 
styles. Use the Match button to select the symbology.  

 
 Select the “Existing Ground” tab. Select the level X_E_Ground_XS, associated 

color, weight and style. Use the Match button to select the symbology.  
 

 Select the “Proposed Grade” tab. Select the proposed grade symbology from 
Slope Stake Cut/Fill to Slope Stake Cut/Fill; define the path to search for the text 
to generate the report. Use match button to select the symbology and use 
highlight button to view selection. Use the Subgrade Template Point Identification 
Sheets as a guide to select the path for the report .  

 
 

Note - Subgrade Template Point Identification Sheets are created with 
project specific information and included with the project specific 
Subgrade Template Report. Template points on the Subgrade Template 
report correlate with the points on the Subgrade Template Point 
Identification Sheets.  
 

 In the Search Text tab:- The “Text” is the text string to search for in the cross 
section. The “Rpt Label” is the label to use in the report to represent the text string 
found. The “Type” is the type of point this text string represents which must be 
centerline, shoulder, catch point or other. Some of the FLH standard search texts are 
included into the Search Text tab default setup as shown below.  
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 The user can manipulate the search text list with the help of edit tools as shown 

above.  
 

Note - Text must be entered as it appears in the cross sections. This 
MVBA is case sensitive. The tolerance value defines the distance the 
application will search for text in relationship to a proposed subgrade 
element vertex. The tolerance value should be around the value as shown 
for both metric and English projects. 
  

 Once all the settings have been defined, Select the Save Settings Icon to save the 
project settings. The project modified Subgrade Template Report settings are saved 
to your working directory as Subgrade Template Settings.sts. Select Save Settings to 
Another File Icon to save your project settings to a different setting file name.  

 

                                        
 

 
 Select Generate Report to create the report with the defined parameters.  

 

                                   
 

 The following dialog will appear asking to provide the name of the subgrade report 
file to be created. Provide a name and Select Save.  
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 Occasionally errors are found in the cross sections. These may be caused by 
incorrect symbology (either in the cross sections or that specified in the dialog) or by 
search text not specified correctly. When an error occurs on any given cross section 
the user will be presented with a dialog similar to the following:  

 

                               
 The description of the error in the dialog will indicate the location and type of error 

that was found.  
 
 

 When the application has finished processing the final cross section in the specified 
range a message will be displayed indicating it is done. Select OK.  
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 Use Cross Section Navigator to view your cross sections with the subgrade traced 

elements.  

 
 The Subgrade Template Report  will produce the following report as shown below. 

The report will be saved in the location specified and can be viewed and printed 
using any text editor application. UltraEdit is preferred for viewing and printing the 
Subgrade Template Report.  

 
 
12/04/2012                                           Test Project 1                                            Page# 20 
                                                         NAMA 17(1) 
                                                        Mainline Road 
                                              SUBGRADE TEMPLATE REPORT (ft) 
 
                                       Left Side                                                         Right Side 
                  ‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐            ‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐ 
   Station        Cut/Fill        Slope      Distance   Elevation    Super       Super    Elevation   Distance    Slope   Cut/Fill 
 
 20+00.00       F 0.94       ‐1:4.00      20.65       121.03 
                                                      16.90       121.97        ‐4.450%         ‐4.450%    121.97     16.90 
                                                                                                          120.47     22.90   ‐1:4.00    F 1.50 
                                                                                                             120.88     25.39    1:6.00    C 0.42 
 
   Station       Easting        Northing        Elevation    Offset                 Id          Slope     Horiz.   Vertical 
                                                                                                         Diff.       Diff. 
 
 20+00.00    1354095.02     498407.91     121.03     ‐20.65  CP 
                                                                                            ‐1:4.00      ‐3.75     ‐0.94 
                1354097.90     498405.52     121.97     ‐16.90  SHLD 
                                                                                     ‐0.045     ‐16.90     ‐0.75 
                1354110.92     498394.74     122.72      ‐0.00  CL                                             0.00      0.00 
                                                                                     0.045     ‐16.90      0.75 
                1354123.93     498383.96     121.97      16.90  SHLD 
                                                                                  ‐1:4.00       6.00     ‐1.50 
                1354128.56     498380.13     120.47      22.90  HPC 
                                                                                  1:6.00       2.49      0.42 
                1354130.47     498378.55     120.88      25.39  CP 
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 The Subgrade Template Reports generated for construction should be 
accompanied by the typical Subgrade Template Point Identification Sheets for the 
project. The Subgrade Template Point Identification Sheet shown below identifies 
the template points in the Subgrade Template Report along a typical cross section. 
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1.14.2 -  Staking Detail Report: 

 

The Staking Detail Report is used to locate the catch points (tie down point between 
the proposed finish grade and the existing ground) at each section. Referencing this 
catch points, the Staking Report lists the left and right offset and its corresponding 
elevation, and the slope of the proposed finish grade.  The Staking Detail Report are 
generated from the cross section file by accessing the XS Report dialog.   

 
 Open the cross section dgn file (01-xxxx_Dxs.dgn) that contains your existing and 

proposed Cross sections. 
 Select the Reports & XS Quantities button from the Project Manager dialog box 

as shown below: 
 

                  

 The XS Report dialog will appear as shown below.   Click User and fill out the 
Report Header Dialog box.  This Report Header information can be saved by 
clicking on File and selecting the path and file name to be saved.   
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 Select the Staking Detail button from the XS Report dialog box. When selected, 
you will get the following dialog box. 
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 To set the symbology values for the Existing Ground Line and Proposed Finish 

Grade, pick the symbology button  to get the following dialog boxes: 

           

 Set the existing ground line symbology as shown above. Select the top of the 
pavement layer, ditch slope, cut slope and fill slope for proposed finish grade. The 
values shown in the Existing Ground Line and Proposed Finish Grade sections will 
allow GEOPAK to progress through the top of subgrade.  This is the path needed to 
get the correct report.   

 

Note - The values shown in the Proposed Finish Grade are only for a 
standard ditch or fill section.  There will need to be additional symbology 
added to the Proposed Finish Grade section if retaining walls and other 
elements are added to the cross sections. 
 

 Once the existing and proposed symbology has been selected, provide a name for 
the report and select Apply to process the Staking Detail Report.  

 
                                                                                         STAKING DETAIL REPORT(Ft)    

                                Slope              Left Stake                                      Right Stake                                                Slope 

   STATION                                C/F      DIST      ELEV    SUPER    ADJ.   SUPER   ELEV.   DIST         C/F               

  18+50.00 R 1        6.00:1.     C  0.99   28.81    126.86   -0.020   128.13   -0.020   126.77    28.27  C    0.89       6.00:1. 

  19+00.00 R 1        6.00:1.     C  0.77   27.55    124.81   -0.020   126.28   -0.020   124.77    25.87  C    0.74       4.00:1. 

  19+50.00 R 1        6.00:1.     C  0.73   27.29    122.92   -0.020   124.45   -0.020   122.60    25.35  C    0.41       6.00:1. 

  20+00.00 R 1       4.00:1       F  0.94   20.65    121.03   -0.020   122.72   -0.020   120.88    25.39  C    0.42       6.00:1. 

  20+50.00 R 1        6.00:1.     C  0.36   25.05    119.27   -0.020   121.17   -0.001   119.84    27.29  C    0.73       6.00:1. 

  21+00.00 R 1        6.00:1.     C  0.66   26.89    118.12   -0.027   119.79    0.027   117.71    28.62  C    0.27DL   -6.00:1. 

  21+50.00 R 1        6.00:1.     C  1.91   34.36    118.06   -0.037   118.57    0.037   118.36    17.34  C    0.59DL   -4:1. 
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1.14.3 -  Blue Tops Reports:  

 Blue Tops reports indicate all breakpoints at the top of base course. Based on FLH-
defined text strings placed on each cross section, GEOPAK determines the offset and 
elevation in addition to the slope between each pair of adjoining vertices. There are two 
reports that are needed; the standard Blue Top Report and the XYZ Blue Top Report 
(provides Northing, Easting values, and Elevations).  To generate this report, access the 
MicroStation file containing the cross sections and select the Blue & Red Top button from 
the XS Report dialog box. 

 Open a cross section dgn file (01-xxxx_Dxs.dgn) that contains your existing and 
proposed Cross sections elements. 

 Select the Reports & XS Quantities button from the Project Manager dialog box 
as shown below: 

 
 

                  

 The XS Report dialog will appear as shown below.   Click User and fill out the 
Report Header Dialog box.  This Report Header information can be saved by 
clicking on File and selecting the path and file name to be saved.   
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 Select the Blue &Red Top button from the XS 
Report dialog box. When selected, you will get 
the following dialog box. 

                                       

 

 

 

 

 

 

 

 

 

 

 Toggle the type of report to be generated, (located at the left of the directory path) to 
Blue.  

 Key in the Job number and Chain.  
   

 If you want notes for the entire chain, highlight the Beg Sta. Field and press 
delete.   The application will automatically set this field to the beginning station 
of the chain.   Repeat this for the End Sta. Field. You may also simply key in a 
desired station range.  
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 To set the symbology values for the Existing Ground Line and Proposed Finish 

Grade, pick the symbology button  to get the following dialog boxes: 

           

 The values defined in the Existing Ground Line and Proposed Finish Grade sections 
will allow GEOPAK to progress through the top of base course. You may need to 
include the top of pavement symbology if the foreslope has the same symbology 
along the base course as the pavement section. The values shown in the Existing 
Ground Line and Proposed Finish Grade sections will allow GEOPAK to progress 
through the top of base course(Aggregate Course) as shown below.  This is the path 
needed to get the correct report.   

 

 

 Keep the Span and Reference button toggle off as shown below.  
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 Select the Text button to bring up the Blue and Red Top Text Set dialog box as 
shown below:  

                  

 Review the cross section to select text at the points that you want reported. For X_30 
FHWA criteria, the text placed on your cross sections on a level named 
X_Text_Search. Review your cross sections and key in the text to search for and its 
description.   Press Add or Delete after each entry.   To Modify an entry, simply 
highlight the entry, adjust the values in the white fields and click Modify. When 
finished … these entry’s can be saved for recalling later, by clicking on the File 
pulldown.   Select the path and filename to save this information. The text set for your 
project can be saved as a *.lis file. 

Note - The EFLHD_Default.lis file is located at 
“M:\Engineering_Software\Cadd_resource_v8i\Standard_Shts\ 
SG_Template\” directory for your project.  Open this file through File 
> Open in Blue & Red Top Text Set dialog and modify according to 
your project information. 

 Prior to running the Blue Top Report, make sure the Blue button is shown in the Blue 
&Red Top Report dialog box. Select Apply to process the report. Report is shown 
below for one cross section. 

                                                             BLUE TOPS REPORT(Ft) 

STATION               SSF         HPF         SHLD_AB   Travelway   Travelway     CL_AB        Travelway    Travelway        SHLD_AB      HPC            
SSC             

-----------------   -------------- -------------- -------------- -------------- ------------ ------------ ----------------- -------------- -------------- ------------ 
20+00.00R1[Ramp]   121.03      121.97         123.20         123.02         123.36         123.22         123.36          123.02           123.20         120.47                       

                   -20.65     -16.90         -12.00         -10.00         -10.00             0.00           10.00            10.00             12.00             22.90              

                              -0.94      -0.250          0.087         0.000           0.013            0.013           0.000            0.087           -0.250          0.167 
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 The XYZ Blue Top Report is the same as the Blue Top Report, just change the 
button that says Blue to XYZ as shown below. Provide a new name for the report 
and select Apply. 

                                       

                                XYZ Blue Top Report 
       Station                      X                          Y                       Z          Offset      ID         SLOPE 
--------------------          ------------       ------------       ------------   --------     ------      ------ 
20+00.00R1[Ramp]         1354097.900     498405.523        121.970    -16.902      HPF    

                                                                                          -0.250    
                            1354101.676     498402.396        123.195    -12.000   SHLD_AB    
                                                                                            0.087    
                            1354103.216     498401.120        123.022    -10.000   Travelway    
                                                                                         0.000    
                            1354103.216     498401.120        123.355    -10.000   Travelway    
                                                                                          0.013    
                           1354110.917     498394.742        123.222      0.000   CL_AB    
                                                                                        0.013    
                           1354118.619     498388.363        123.355     10.000   Travelway    
                                                                                           0.000    
                           1354118.619     498388.363        123.022     10.000   Travelway    
                                                                                           0.087    
                           1354120.159     498387.088        123.195     12.000   SHLD_AB    
                                                                                          -0.250    
                          1354128.556     498380.134        120.470     22.902   HPC    
                                                                                           0.167    
                          1354130.474     498378.545        120.885     25.392   SSC    

 


