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SECTION 4:  Geopak – GIS 

4.1 - Set a Geographic Coordinate System in a Microstation DGN 
 

Sharing a common coordinate allows DGN files to correctly reference each other. In order to have 
interoperability with other files, such as aerial photos, GIS files and other geo-referenced files, there 
must be a geographically defined coordinate system.  Having known coordinate systems allows 
translation between source (i.e. aerial photo) and destination files (i.e. DGN horizontal alignment). 
Using MicroStation tools, DGN files can be assigned a known or custom Geographic Coordinate 
System (GeoCS or GCS). There are many coordinate systems available to choose from.  The Survey 
and Mapping office has intimate knowledge of coordinate systems and should be consulted before 
using GeoCS tools. They can assist in identifying the proper GeoCS. 

Select a Geographic Coordinate System 

With MicroStation open, go to File > Geographic > Open as ToolBox. The Geographic menu appears.  

Select the globe icon to Select Geographic Coordinate System. 

 

The Geographic Coordinate System menu appears.  Note the dialog below shows that a GeoCS has 
not been assigned.  There are several methods to select a GeoCS. The following three are described 
below: 

• From Library  

• From Reference  

• From File  

 

 

 

 

https://flh.fhwa.dot.gov/resources/cadd/tips/geo-coord.htm#library
https://flh.fhwa.dot.gov/resources/cadd/tips/geo-coord.htm#reference
https://flh.fhwa.dot.gov/resources/cadd/tips/geo-coord.htm#file


 
 

 Page 4-3 
 

EFLHD CADD Procedures Guide – GEOPAK V8i Edition Chapter 4 –                        
GEOPAK V8i - GIS 

 

From Library 

The From Library method involves choosing a GeoCS from a large library. Consult the Survey and 
Mapping office to identify the proper GeoCS.  

 

Below is an example of GeoCS list for the state of Montana. Generally, systems used will be from the 
Library > Projected (northing, easting -) > North America > United States of America > State.  
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From Reference  

The From Reference method is the easiest and the preferred method.  This method allows the 
inheritance of a GeoCS from an attached reference file that has a GeoCS defined.  The preferred 
source file is the PLM file produced by the Survey and Mapping Department. Inquire with Survey and 
Mapping to asses if a GeoCS has been assigned.  

 

 

Next select the reference file to inherit the GeoCS from. Then select OK. Note the GeoCS has been 
assigned to the project PLM file. 
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From File 

The From File method functions much like the From Reference method.  Using this method requires 
selecting a file using a standard select file menu.  As a best practice use the project PLM file. 

 

 

Select the appropriate file. Then Select Open.  Inquire with Survey and Mapping to asses if a GeoCS 
has been assigned.  
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Verification 

Once a GeoCS has been selected the Geographic Coordinate System menu should be populated and 
appear similar to the dialog below. 

  

The Reference menu will show the GeoCS name if assigned. Note; if the GeoCS column is not listed, 
Right-click on a column heading and add it.  
 

 

 

 

Google Earth Verification 

Many users have Google Earth Pro installed. The Geographic Menu has Google Earth tools that can 
synchronize drawing locations in Google Earth and conversely, synchronize Google images in 
drawings. 
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Once the GeoCS has been assigned, zoom into an area that would be recognizable in an aerial view. 
Separately open Google Earth Pro. Then in MicroStation select the Synchronize Google Earth View. 
The Google Earth view should be updated to show the corresponding area in the drawing. 

 

Now within your project parameters, zoom to an area of interest in Google Earth Pro. Use the 
Follow Google Earth icon to update your drawing view to correspond with the Google Earth view.  
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4.2 - Georeference Google Earth image into Microstation 
 

Georeferencing from Google was previously available only in Microstation GeoGraphics and Bentley 
Map. 

 Microstation V8i (SELECTseries 3) provides support for geographic coordinate system setup and on-
the-fly reprojection of references in different coordinate systems. This geographic coordinate system 
support allows for easier integration with ArcView Shapefiles, Google Earth, and GPS devices. 

 

  
Open the dgn file or model 
you want to reference the 
Google image into. 
 
The dgn/model MUST be 3-D. 
 
Start Google Earth by double-
clicking the desktop shortcut 
(if you have one) or start it in 
the cadd file by navigating to 
Tools >  Geographic > Follow 
Google Earth View . 
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In Google Earth, “fly to” 
the general area of the 
image you want to 
capture. 
 
 
Toggle on or off, the 
layers you want displayed 
in the image; Roads, 
Parks, Water Boundaries, 
Labels, etc. 

Zoom in or out as needed 
To fit the desired view 
area. 
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To quickly check if you have selected the correct coordinate system, use the “Synchronize Google 
Earth View” tool; 

 

 

  

 

This tool uses the coordinate system you’ve selected along with the current view in Microstation and 
will then “fly to” the same location in Google Earth.  

  

Back in Microstation, you will need 
to set the proper Geographic 
Coordinate System. 
 
 
Go to Tools > Geographic > Select 
Geographic Coordinate System 

Follow the steps above in Section 4.1 for selecting the Geographic Coordinate System. 

Synchronize Google Earth View 
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To import the image into your 
dgn file, Go to Tools > 
Geographic > Capture Google 
Earth Image. 
 
 
The Microstation prompt (at 
the bottom of your cadd 
window) instructs you to 
“Enter datapoint to capture 
the current Google Earth view” 
 
 
Datapoint in the view. 
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A grid will appear showing the 
limits of the Google Earth 
image. 
 
(If the grid is not within the 
limits of the project, an 
incorrect coordinate system 
was probably used.) 
 
 
 
 
 
 
 
 
 
 
 
Go to Settings > View 
Attributes. 
 
Open the Display Style drop 
down and select SMOOTH. 
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The Google image is now showing, 
georeferenced into the cadd file at the 
correct coordinates, scale,  projection and 
rotation. 
 
If your dgn/model had mapping or 
alignments active or referenced, the Google 
image may  be on top of those elements.  
You may not be able to see them. 

The reason you may not see your active dgn 
elements is that the 3D Google image you 
just referenced is at a HIGHER “Z” elevation 
than the active elements. 

To correct this, fit the area in View 2 (the ISO 
view).  You will see the grid in isometric 
view. 

MOVE the grid to a lower elevation by using 
the AccuDraw Tool. 
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Select the grid with the MOVE command. 

Hit “T” (for Top). 

Enter value 0 in the X field, 0 in the Y field 
and -50 in the Z field. 

This should move the referenced image 
BELOW your active elements. 

WARNING: 

Because of moving the image, you should 
not use the georeferenced image for 
identifying or labeling elevations. 
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4.3 – View Geotagged Photos in Google Earth 
 

What is a geotagged photo? 

A geotagged photo is a photo taken with a camera that has a GPS function that is turned on at the 
time the photo is taken, so that the geographic coordinates of the photo location are saved in the 
photo’s data file.  

To check whether a photo is geotagged, right-click on the photo name in Windows Explorer and 
select Properties from the drop-down menu. Click on the Details tab in the photo properties 
dialogue box that opens. 

 

Figure A-1 

When you scroll down through the available Detail information, if your photo has latitude and 
longitude information (Figure A-1), it is a geotagged photo and can be used to create a shapefile. 
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A. Create a Shapefile from Geotagged Photos 
 

1. Open ArcMap (either create a new map, or use an existing map). 
2. Make sure that ArcCatalog has a connection to the folder where you saved the photos. To 

create a new folder connection, click on the icon at the top of the Catalog window that looks 
like a yellow folder with a plus sign (where the red arrow is pointing in Figure B-1). 

 
Figure B-1 

Navigate to the folder you want to connect to and click on it (the folder’s file path appears in 
the Folder entry box). Click OK. (Figure B-2) 

 
Figure B-2 
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3. Open the GeoTagged Photos to Points tool in ArcToolbox by navigating to the tool in Data 
Management Tools  Photos, and double-clicking on the tool Figure B-3). 

 
Figure B-3 

 
Click on the folder icon next to the Input Folder entry box (Figure B-4) and navigate to the 
folder where your geotagged photos are saved. Click once on the folder so that the folder 
name appears in the Name box, and click Add (Figure B-5). 

 
Figure B-4 

  



 
 

 Page 4-18 
 

EFLHD CADD Procedures Guide – GEOPAK V8i Edition Chapter 4 –                        
GEOPAK V8i - GIS 

 

 
Figure B-5 

 
For the Output Feature Class entry box, select the folder where you want your new shapefile 
to be saved, and enter a name for your shapefile (Figure B-6). Click Save. 

 
Figure B-6 

In the GeoTagged Photos to Points dialog box, decide whether you want to include non-geo tagged 
photos in your shapefile, and check/uncheck the box accordingly (Figure B-7). Click OK to run the 
tool. 

 

Figure B-7 
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When the tool finishes processing, your new shapefile should have been added to your map in the 
Table of Contents, and you will see some points on your map (Figure B-8). 

 

Figure B-8 

4.  You can add a basemap layer to check that your photos have been placed in the 
correct locations. 

 
Figure B-9 
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5. Add new fields (columns) in the attribute table for latitude and longitude information, and 
photo description (optional). Open the attribute table by right-clicking on the shapefile 
name in the Table of Contents and selecting Open Attribute Table from the drop-down 
menu. Click on the icon located in the top left of the attribute table, and select Add Field… 
from the drop-down menu (figure B-10). 

 
Figure B-10 

Enter LatDD for the field Name (for latitude in decimal degrees) and select the Type: Float (Figure B-
11). Click OK. [N.B. Do not use spaces in the field names. You may use underscores.] 

 

Figure B-11 

Repeat for the LongDD field (longitude in decimal degrees). For the Description field, enter Desc for 
the field Name, and select the Type: Text. You must enter in the maximum number of characters 
that will be allowed in the Description field (e.g. 100 characters). This cannot be changed once the 
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 field is created, but a larger number will increase the amount of disk space your shapefile will 
occupy. Therefore, carefully consider what is most appropriate for the character limit (Figure B-12). 

 

Figure B-12 

6. Use ArcMap to populate the latitude/longitude information in the attribute table. ArcMap 
knows the lat/long of your pictures, since it has accurately placed them on the map. 
However, you need to direct ArcMap to “calculate” these values to fill in the attribute table. 
 

Right-click on the latitude column header, LatDD, and select Calculate Geometry from the drop-
down menu. You will receive a reminder that you are about to calculate outside an edit session. 
Click Yes. Make sure that the Property is set to “Y Coordinate of Point” (since you are calculating 
the latitude). The units will be in decimal degrees because of the coordinate system from the 
GPS camera (Figure B-13). Click OK. The LatDD column will be filled with the latitude information. 
Repeat these steps for the LongDD field, making sure that the Property is set to “X Coordinate of 
Point.” 

 

Figure B-13 

7. Enter photo description information. To add photo description information to the attribute 
table, you must start an edit session. Right click on the shapefile name in the Table of 
Contents and move your cursor down to Edit Features, then select Start Editing.  
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If the Editor toolbar does not appear automatically, click on the Customize menu at the top of the 
ArcMap window and place your cursor over Toolbars. If the Editor toolbar is unchecked, click to 
check it. The Editor toolbar will appear (Figure B-14). 

 

Figure B-14 

Now you can edit information in your attribute table. Double-click on any row in the Description 
column, and a cursor will appear indicating that you can enter information. 

Once you have completed all your edits, click on the Editor dropdown menu in the Editor toolbar, 
and select Stop Editing. If you have unsaved edits, the program will prompt you by asking whether 
you would like to save your edits. Click either Yes or No to stop editing. 

1. The Identify tool (Figure B-15) can be used to see the attribute information for any point 
(photo location). Click on the Identify tool to activate it (Figure B-15). 

 

Figure B-15 

The Identify window will open, containing attribute information for the point you clicked on (Figure 
B-16). 
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Figure B-16 

C. Creating a KMZ for Display in GoogleEarth 
1. Locate the Layer to KML tool in ArcToolbox  Conversion Tools  To KML  Layer to KML. 

Double-click on the tool to open the dialogue box. Select your shapefile (with the photo 
locations) from the Layer dropdown menu (or navigate to its location by clicking on the 
folder icon). (Figure C-1) 

 

Figure C-1 

2. Click on the folder icon next to the Output File entry box and navigate to the folder location 
where you would like to save your KMZ. Enter a name for your KMZ file into the file name 
box (Figure C-2). Click Save. 
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3. In Windows Explorer, navigate to the folder where you saved the KMZ file. Double-click the 
KMZ file to launch GoogleEarth. Your photo locations will be shown as points. If you click on 
one of the points, a pop-up window will open containing the same information that was in 
the attribute table (Figure C-3).  

 

Figure C-3 

It is possible to create a KMZ so that the photo appears in the GoogleEarth pop-up window when 
you click on a point. As this process is considerably more complicated, please contact Engineering 
Support for assistance if you would like to do that. 
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4.4 – Visualize the Horizontal Alignment (Chain) in Google Earth 
 

Follow these steps to georeference the centerline chain in GoogleEarth; 

In the Microstation design file that has the alignment centerline, set/verify that there is a geographic 
coordinate system (GCS) assigned to the drawing. 

In the CADD file, go to  File > Geographic > Open as ToolBox. The Geographic menu appears.  

Select the globe icon to Select Geographic Coordinate System. 

 

The Geographic Coordinate System menu appears.  Note the dialog below shows that a GCS has not 
been assigned.  There are several methods to select a GCS. The following three are described below: 

• From Library  

• From Reference  

• From File  

 

 

  

https://flh.fhwa.dot.gov/resources/cadd/tips/geo-coord.htm#library
https://flh.fhwa.dot.gov/resources/cadd/tips/geo-coord.htm#reference
https://flh.fhwa.dot.gov/resources/cadd/tips/geo-coord.htm#file
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From Library; 

The From Library method involves choosing a GCS from a large library. Consult the Survey and 
Mapping office or the delivered mapping .dgn to identify the proper GCS.  

 

Below is an example of GCS list for the state of Montana. Generally, systems used will be from the 
Library > Projected (northing, easting -) > North America > United States of America > State.  

 

Hit OK. 
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Verification 

Once a GCS has been selected, the Geographic Coordinate System menu should be populated and 
appear similar to the dialog below. 

  

Now, fit the alignment centerline in the Microstation view. 

Turn off any Reference File display and/or Levels of any elements you do not want shown in 
GoogleEarth. 

Go to File > Export > GoogleEarth > Navigate to the destination path for the .kmzr. 
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Hit Save and GoogleEarth is opened and it zooms to the coordinates of the design file. 
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